Lost Privilages

I have 2 admin accounts, one has never been able to select 'Public' when creating pages or disussions (1.8.3). However, since upgrading to 1.8.5, neither of the admins have the Public option in Read Access nor 'Write Access'. I am also not able to save a newly created page, it throws a 403. If I edit an existing page I can delete text etc without a hitch, but adding anything throws the 403.

  • It appears that the problem is confined to one Group only. Very strange; but there again I'm good at things, which is why I'm not allowed to have nice things.

    If I made a new Group is there a simple way of migrating the data into it from the original Group; or am I up for a bit of copy 'n' pasting?

  • That's very strange... I have no idea

  • I excel at strange. The Group is the oldest one on site and I wonder if I originally created it as Private. I know I originally tried different settings to see what could and couldn't be done, maybe the chopping and changing came unstuck on the upgrade to 1.8.5.

    No biggie; I'll just spend some time recreating the Group and content.

  • Time to throw in the towel I'm afraid. I made a new Group and started copying over the content. All was working fine; I had all the normal read/write options available and I was happily storming ahead. Until...I tried to edit a page to correct a spelling mistake. 403. I went to edit other pages/discussions. 403.

    I shall keep my test site up and running, but I'm afraid spammers and my inability to keep my main Elgg site stable has broken my enthusiasm. I simply don't trust myself to keep the Elgg side of things running smoothly enough to open it to the public. 

  • A 403? Did you ask your hosting support if there's a problem within your hosting account? I don't think Spammers will cause a 403 error


    Have you tried RayJay Spam Filter plugin? I have pretty good results against spammers and also it offers the ability to block IP based on countries. 

    (It works much better if you have fassim API Key)

    Rodolfo Hernandez

    Arvixe/Elgg Community Liaison

  • The spammers didn't cause the 403s. Simply turning off the 'Allow New Users to Register' solves the spamming problem. The problem isn't at the hosting either as I have another Elgg installation with the same company; and that works fine. I receive 403s whenever I try to edit one of my own posts in a new Group, or, whenever I try to make a new Page/Discussion in an older Group. Other Groups are fine.

    My public site is forum based and I was looking to social networking to replace the forum section; however, after 6 months of installing/uninstalling, glitch fixing and locking out our good friends from the spam community I have decided to keep the forum and abandon the social network idea. Having said that, I won't give up on my learning curve and I'm just not far enough up the curve to confidently open the doors.  

  • I knew it would be my fault, and I'll bet it's common knowledge. I hate giving up so I created a new user and tried to make a new page. All good. I copied the content from the old post, all good. Tried to edit it to add the additional piece of content I got the 403. Adding the additional content in a Sub Page works as expected.

    Likewise, splitting the content of the other post (an imported Word doc) works as well; although it was imported ok originally. I still don't know why one of my admin accounts can't invoke the Public option in Read/Write Access, but that's an easy fix.

    Just thought I'd let you all know where I'm up to :)

  • Hmmmm. Trying to upload a Word doc which is only 45KB. I'm receiving the '403 Access to this resource on the server is denied!' Is there a global size restriction somewhere? It can't be the hosting company as I have FTPd a 305MB file earlier today.

  • Hi, well ftp is one thing. You need to check your php settings. I believe it is the hosting that is giving you issues with elgg.

    Rodolfo Hernandez

    Arvixe/Elgg Community Liaison

  • Today I was able to upload the 250KB Word file, but not a 422KB PDF. Copying an existing page into another section also produced a 403, as did the 'paste from Word' of the same content.

    Doing the exact same thing on my test site (same hosting) works fine.