your data directory does not exist


I've done many many installs of elgg and today is first time im coming across this error: Your data directory /var/www/clients/client1/web5/data_dir/ does not exist.

The directory absolutely does exist and has the correct permissions. I have tried everything - skipping the step, setting different permissions on the data folder, restarting apache and nothing...anyone seen this crazy error before??

Im on an ubuntu server and im using isp config 3 and elgg-1.8.3

  •         // check that data root exists
            if (!file_exists($submissionVars['dataroot'])) {
                $msg = elgg_echo('install:error:datadirectoryexists', array($submissionVars['dataroot']));

    kinda says datadir does not exist.. 
    for some reason or other..

    so.. the code reckons it " absolutely does not exist "..
    make it " exist.. "


  • i commented out that line just so it would get past that step. im still left with a non-functioning site:

    dont know if the problem now is related to data directory. i think theres a problem with isp config and elgg. it creates a sysmlink when creating the folder to put the client website. that seems to be messing up everything - the data directory and css

  • This is very odd. in Elgginstaller.php, when is does:

            if (!file_exists($submissionVars['dataroot'])) {

                $msg = elgg_echo('install:error:datadirectoryexists', array($submissionVars['dataroot']));
                return FALSE;


    it always fails. im emailing myself the contents of $submissionVars['dataroot'] to make sure its getting the correct data directory string, which it is. Then, when i make a simple php file that checks the existence of my data directory and put it in /var/www/, it finds the directory!

    does anybody have any idea why file_exists will work in root but not in the elgg install folder??? im using the full path to data directory which is: /var/www/clients/client1/web5/data_dir


  • finally got round it by putting php_admin_value open_basedir none in the vhost. site still not working as u can see in my other post