No icons, no images... completely desperate

Hello everydoby,

let me introduce myself , I´m qverde and I´m creating a social network using elgg.

On my project, pictures are quite important, but I have a big problem, they are not shown. it´s imposible to show icons or any picture wich is not install on _graphics folder.

I spent last week seeking for a solution here, on another forums, google... and I can´t do it.

aparently everything it´s ok, and on my local network images works great, but on the server they are missing.

I´m using 1.8.3 version, server is compatible according to install text, and except for this, elgg works great.


Thanks a lot.


  • I had this problem before on elgg 1.8.3. Have you created your own plugins? Do the default images work when you dont upload an avatar? For me, this was happening and it turned out to be a problem with the language files. When i put a ?> at the end of a language file, images weren't displaying for some reason. Try removing ?> from end of language files in all third party plugins. Worked for me..

  • Thanks Mark!

    Actually I don´t create any plugin by my own, I only installed plugins made by other people download from this site. I´ll try to change that in languages files.

    I´ll try it in a clean installation, because I installed again from zero in another folder and images weren´t shown.

    Thanks once again and I´ll post the results of your proposal.


  • If you created the Elgg installation on your localhost, then transferred it to your live server you most likely forgot to move the data directory, or you forgot to update the database with the new location of the data directory.

  • Hi again,

    Matt Beckett - thanks! I´ve checked the database config and all the data seems to be correct, according to elgg´s instruction for moving to local to server.

    Mark - thanks! I´m trying to find that ?> at the end of the en.php file, but I can´t find it. I´m not sure if this is the correct file to check it.

    I´ve tried anothe clean installation using 1.7 version, but I have the same problem.

    thanks both of your for your help.

  • Hi qverde, i have the same issue as yours, did you find a way to fix it ?



  • Sorry to answer to late,

    Finally I have solved my problem. It was a misconfiguration on the hosting. The hosting company changed a configuration and it started to work properly.

    Thanks to everyone who tryed to help!