File uploads fail- PLEASE HELP

When I try to add an icon/picture I get an error message saying "Avatar upload failed", regardless of how small I make the file. When I try to add a file, it says "There was an error uploading the file".......PLEASE HELP ME FIX THIS PROBLEM!!!
I really need help.... 

  • Hi,

    Do you have GD installed? Does your server meets the elgg requirements?

    Could you please check the error log? Also check the file upload size allowed on your server.

    Rodolfo Hernandez
    Arvixe/Elgg Community Liaison

  • Hey Rodolfo,

    Thank you for you're fast response. I believe my server meets the elgg requirements because I've installed it before and it worked fine untill spammers crashed it and I had to remove it. Now I have installed it again it a different subdomain and everything seems to work, but the uploading process. I am hosted with godaddy and the server details say: 
    OS/Hosting Type: Linux / Shared Hosting, Hosting Configuration: 2.2PHP Version: PHP 5.2, MySQL Version: 

  I assume that I have GD installed (for graphics processing: user and group profile icons plus many plugins) do I check to see if it is installed properly?

  • Ok, were you able to upload files on your previous elgg site? What about profile pictures? Did you check the size for uploads on your server? Which version of elgg are you using?

    Rodolfo Hernandez
    Arvixe/Elgg Community Liaison

  • I have uploaded massive sized files before with no problem. I can't access the error log though. Is there something I am missing? Please help...

  • Yes, on my old elgg site, I uploaded over 50 files of varying size and had about 20 members with profile pictures too. It worked fine until it was hacked and I deleted it.

    I am still with the same hosting service and it says elgg 1.8.3 was Successfully Installed in my hosting management. There is no limit for uploads on my server if I have room and I have plenty of space left (about 9gb unused).

  • ok, Iwant2learn, Did you deleted the old database and made a new one?

    I believe you need to contact your hosting tech support and talk about this problem. If it was working before and not now, it means something changed on the server. Of course if you are still using the old database that could be the problem.

    Rodolfo Hernandez
    Arvixe/Elgg Community Liaison

  • This is the only database I am running on the site and the old ones were completely uninstalled and deleted before the new one was installed. I contacted godaddy Online Support and this is what they said:

    I understand that we are currently working on uploading files to your database.  I have reviewed your account and have found that your hosting account is set up and functioning properly.  I have also gone through and tested your database set up with us and everything is working correctly with it as well.  If you are still having this issue you may need to enable your error logs so that you may view why the error is being generated.

    NOTE: Error logs are not available on Legacy Economy Linux Shared Hosting plans. 


    So, I can't afford to upgrade from shared hosting and don't have access to the error logs......can we figure out the problem with out the error logs? is the new elgg database link:

  • Hi!

    Ok, you don't need to upgrade.

    Can you check on the file .htaccess the file upload limit? Open .htaccess and look for the file size limit.

    Rodolfo Hernandez
    Arvixe/Elgg Community Liaison

  • Hey Rodolfo,

    Thank you for getting back with me! I'm very greatful for your patience with me. Is this what you're talking about:

    # php 5, apache 1 and 2

    <IfModule mod_php5.c>

    # limit the maximum memory consumed by the php script to 64 MB

    php_value memory_limit 64M

    # register_globals is deprecated as of PHP 5.3.0 - disable it for security reasons.

    php_value register_globals 0

    # post_max_size is the maximum size of ALL the data that is POST'ed to php at a time (8 MB)

    php_value post_max_size 8388608

    # upload_max_filesize is the maximum size of a single uploaded file (5 MB)

    php_value upload_max_filesize 5242880

    # on development servers, set to 1 to display errors. Set to 0 on production servers.

    php_value display_errors 0


  • Yes, ok, so any file less than 5 MB gives you error?

    Let's try this:

    change this:

    php_value post_max_size 8388608

    To this:

    php_value post_max_size 50M

    And this:

    php_value upload_max_filesize 5242880

    to this:

    php_value upload_max_filesize 50M

    Rodolfo Hernandez
    Arvixe/Elgg Community Liaison