Unable to get any email notifications

Hi All,

I am new to the elgg world, I have installed the elgg successfully but i dont get any notification email. (As i also selected the email option in the notification section). 

I also used the PHPMailer plugins where i used the gmail smtp as

  • SMTP Host: smtp.gmail.com
  • my gmail userid and password
  • Use SSL Authorization [checked]
  • Port Number: 465

But this also doesn't work. Again no notification.

Do i am missing something? Do i have to setup some smtp / mail server? Please guide. 




  • make sure you check your gmail trash, I had a bad filter and it was trashing the email before I could read it.

  • also, if you are using it from localhost (or a test server on your residential connection), many ISP's block outgoing mail ports unless they are routed through the ISP's mail server.  If that is the case you can use the ISP smtp server instead.

  • @Steve Aquila: Yup i check both the trash and spam folder. But nothing is there. So do we have to do additional config things to setup the email notifications?

    @Matt Beckett: Yes i am using localhost and its residential connection. Will co-ordinate with the ISP on that and will come back to u.

    Well Is there is something which i am missing or do we have to provide any additional configuration for the email after installing?

    Thanks Steve and Matt for your support!!

  • Anybody can help/guide me to setup the email notication. I am really get stuck in the email notifcation, dont know why the email is not coming.

    Do we have to add additional configuration for setting up the email notiifcation. Or by default it is pre-setup. Any guidance will be appreciated.



  • This is server dependent. Elgg uses PHP's mail function. This is configured in php.ini on the server. In addition, your hosting provider may have additional requirements for sending mail. For example, some may require that the "from" address exist as a mail account on the server.

  • @Cash: Thanks for replying. But i am using it locally (not yet hosted).

    In php.ini file, i am Configuring as

    • SMTP = localhost smtp.gmail.com
    • smtp_port = 25 465
    Is there is anything else that i should do. (Any additional configuration required)