Elgg 1.8.3 / XAMPP 1.7.7 install problem

I'm trying to install Elgg 1.8.3 on a fresh install of Xampp 1.7.7 on a RedHat Linux 5U4 system.  I've also tried on a previosly existing Xampp 1.7.4 server.  I've done the install of previous Elgg versions lots of times before but this time I'm stumped.  When I get to the requirements checking stage of the Elgg installer I get an error:

  • We think your server is running the Apache web server.

    The rewrite test failed and the most likely cause is that AllowOverride is not set to All for Elgg's directory. This prevents Apache from processing the .htaccess file which contains the rewrite rules.

    A less likely cause is Apache is configured with an alias for your Elgg directory and you need to set the RewriteBase in your .htaccess. There are further instructions in the .htaccess file in your Elgg directory.

mod_rewrite is installed and working properly.  I've tried everything with .htaccess and httpd.conf as described in the error and can't get it to work.  Elgg 1.8.1 installed fine on the same server.  Any idea why I have problems now with Elgg 1.8.3?  I have a feeling I'm missing something really simple.  So far my google searches haven't turned up any clues.

  • @morepower Try this: http://community.elgg.org/pg/forum/topic/826690/the-rewrite-test-failed/

    I know it's a hack, but worked for me in this specific case. Core team, sorry about still not reporting this issue in trac, but I never got the time to properly test what settings/environment can trigger it.

  • We have had 2 or 3 reports of the rewrite test failing when it should have passed. Unfortunately, none of those reports came with any details for figuring out why this is happening.

    In this case, I don't believe anything changed between 1.8.1 and 1.8.3 in the rewrite test. It is quite possible that the test should be failing. If you hit the URL in your browser and it works, the test should be passing: http://mysite.com/rewrite.php (Obviously, replace mysite.com with your own site domain name.)

  • @morepower

    if you are installing elgg on subdirectory then this error occurs i know this already please copy elgg source to root directory and try!


    in Default .htaccess

    If Elgg is in a subdirectory on your site, you might need to add a RewriteBase line

    containing the path from your site root to elgg's root. e.g. If your site is

    http://example.com/ and Elgg is in http://example.com/sites/elgg/, you might need

    RewriteBase /sites/elgg/

  • I did a search and didn't find rewrite.php anywhere in the elgg 1.8.3 I downloaded yesterday.  I couldn't find anything with rewrite in the file name actually.  I did write a basic rewrite rule and that worked.  I also verified that mod_rewrite is loaded.  I'll take a look at the workaround Andras suggested and see what happens.  This is just a test install on a test server so no harm done by poking around.

    Cash, let me know what info I can get for you to help.

  • rewrite.php does not exist. In .htaccess there is a rewrite rule that routes requests for that file back to the installer.

    So are you saying that if you hit the rewrite.php page in your browser, it works?

  • I see it now... and no, it doesn't work.  I do have other rewrite rules on other parts of the site working fine.  I worked around the problem as Andras suggested and got it installed.

    In the .htaccess I commented out <IfModule mod_rewrite.c> and it's corresponding </IfModule> to force the rewrite to turn on and the rules to kick in.  Pointing the browser to rewrite.php yields success.