Cannot upload Avatar - 1.8


I'm going mad, because in my site i can't upload an avatar.

I choose an image, I get the message "avatar succesfully uploaded" but nothing happens.

I reinstall ellg as-is, nothing added yet.

Help! :-(


    • Check whether you are able to upload an image of small size as profile image.
    • Are you able to upload the same image through the file plugins?
    • Make sure GD library is enabled in your host.
  • Check whether your data folder has access of 777.

    The steps from Webgalli should be the key.

  • Thanks to all, here the test's result:

    • I tried to upòload a 3kb image, nothing happens;
    • Though the file plugin the same file was uploaded B-O
    • GD library are enabled (verified with var_dump(gd_info()))
    • data folder has 777


    Any other idea?


  • Whats the result when the same image is uploaded through file plugin? You got the thumbnails?

  • No thumbnail, only the title. I can see the image if i clic on "download this"


  • I tried to install the tidypics plugin, it uploads the image, in the second part (where i can add a title, a description, etc...) I don't see the thumbnail ("?" icon) but when I save, I can see either the thumbnail in the album, either the original pic.



  • Are you using 'video list' plugin? My case happened with this plugin.

    When it happened it was necessary to disable and enable some plugins to make the system return!

    My suggestion: try it! (At the beginning, just let the 'basic core Elgg' and then start to add plugins, and run 'upgrade.php' after each enable)

    Please, make some notes! Report your experience!


  • @Cerccau: i already started using the basic core of elgg as I downloaded it...

    nothing :-(((


  • Try installing the preview version of the Tidypics plugin for 1.8. It has more diagnostic information for uploading and resizing images than Elgg core. Also, check your server's error log.

  • @Aki76

    Whether you'are running Apache or Nginx as the webserver (I am assumimg you're using Linux), you need to make sure that the owner of the data folder is the same user under which your web server is running.

    Is this not the case, do the following to change the ownership:

    chown  -R  <user account name>   <data folder path>