Lots of, difficult to locate, 'deprecated' errors since upgrading 1.7 to 1.8

I recently upgraded my site from 1.7 to 1.8 vrs 2011110700 by dropping 1.8 onto the site and running upgrade.php which worked surprisingly well except I am getting errors such as the below one in all sorts of unexpected places. The below is with the latest Profile Manager plugin for 1.8 when I enable the 'profile type' selection, these appear in the registration page. The thing is it doesnt happen on my 1.8 development site which was created using 1.8 from scratch. I get these messages with a lot of plugins that are supposedly 1.8 plugins on my upgraded 1.7 site.

I tried deleting the \engine folder completely and replacing it with 1.8 \engine folder which sorted out some of the plugins, but still getting the below with a lot of them, and it doesnt seem to be coming from the plugin itself, or the \engine folders, so where else might be giving me this problem?

WARNING: Deprecated in 1.8: input/pulldown was deprecated by input/dropdown Called from [#14] /var/www/clients/client1/web4/web/engine/lib/views.php:473
WARNING: Deprecated in 1.8: You should pass $vars['id'] now instead of $vars['internalid'] Called from [#15] /var/www/clients/client1/web4/web/views/default/input/pulldown.php:9
-> [#14] /var/www/clients/client1/web4/web/engine/lib/views.php:473


Feedback and Planning

Feedback and Planning

Discussions about the past, present, and future of Elgg and this community site.