Privecy policy

How do I enable privecy policy ( a site page) at Registration page? I do not allow any body to see any content of the site before registration and accordingly I configured in " advance Setting" But Google Adwords team want privecy policy should be visible before registration. Is there any solution?

  • Q1:      Which Version of Elgg are you talking about ? 
    Q2:      Have you gone through the Admin Settings of your Elgg install ?
               The switch there for "The default access permissions:"
               Have you seen that yet ? If not - you should be more curious.. ;-)
               Curiosity helps people to learn new things quickly ;-X
    3/NB:    " not allow.. content.. before registration.." --
               This might/most probably take a fair little effort more to make
               it work; And it will help if you can code PHP and have some
               reasonable unbderstanding of programming principles, do you have that ? 

    4:        "any Solutions.' ? Yes of course, there's always solutions for any problem
               Sometime we have just havce to work a little bit harder to get them ! ;-)


  • 1. I am using Elgg 1.8

    2. I think you are over enthusiastic and did not read my post carefully. If I do not know the basic and advance settings how did I rstrict user not to see any content before registration?

    3. Is it required to have programming knowledge to run a site on ELgg platform? I thing basic knowledge of programming is enough to edit codes

    4. You have not given any solution to my problems, rather try to advice me which I do not require. I require solution of my problem and not " baseless speach"

  • The bundled External Pages plugin would allow you to create "About", "Terms" and "Privacy" pages. If the plugin is enabled the configuration of these pages is possible in the Site Administration section (Configure - Appearance - Site Pages). But it seems these pages are not viewable, if the site is set up for "Logged in users only". I think this is not the intended behaviour, i.e. this is a bug. I don't know if Elgg 1.8.1 will fix this issue, i.e. if it has been reported already. I'm afraid with Elgg you would need to go bug-hunting on your own to fix it.

  • I opended a ticket for this issue at Trac. But it might be too late to get this issue to be fixed in Elgg 1.8.1...

  • many many thnx for understanding the exact problem and steps taken for solution. I hope, 1.8.1 may fix this bug

  • I verified the code and the database -- There is no "bug" - in Elgg. - the ExPages PlugIn sets the entities' ACCESS ID = "2" for Public (i.e. logged-out) and so these Ex-Pages are not a problem and they work as expected and are viewable when logged-out ;-) No need for that TRAC ticket b/c => mis-informatio -- Ticket #3947 is redundant... ;)

  • Dhrup, I think the problem is with the walled garden setting. If it is set, then nothing gets through. It sets an index hook with the highest priority which puts up the login box.

  • well:
    -- quoting "... think.."
    and here I go ackshully reading code ! ;-)
    so here's possible solution, for (any)one that wants to code into the correct area(s)
    -- plugins generally are able to register their own hooks --
    //register walled garden public pages
    elgg_register_plugin_hook_handler('public_pages', 'walled_garden', 'expages_public_pages');
    // registers public pages to allow in the case walled garden has been enabled.
    function expages_public_pages($hook, $type, $return_value, $params) {
        $return_value[] = . . .
    shud woiky ;)


  • ohh btw - there's also a plugin that handles this walled-garden w/ exceptions feature already.