Problem installing Elgg 1.7.12- no clue why it isn't installing

I have been trying for hours to install Elgg on my new domain. I have read every discussion I could find relating to Troubleshooting Elgg Installation but nothing even sounds like my problem. I am pretty sure I followed all of the instructions correctly but for some reason I can't get Elgg to work. I have made a few other websites, but installing that software was simplier than Elgg because my host (Dreamhost) had a "One-Click-Install" for the otehr software I used.

This is the steps I took:

I downloaded the most recent Elgg download.

I unzipped it.

I used the webftp program on Dreamhost to upload the Elgg directory onto my website in the root directory (I want the main page of my website to be Elgg).

I created a MySQL database.

Dreamhost suggested I name the database sigmicron_elgg so I did.

I changed the name of the directory in my FTP to sigmicron_elgg.

My website still has the standard "Coming Soon" page provided by Dreamhost.

I tried installing the Elgg software in my FTP like this:


Then I went to and the page looked like this:


So I deleted that directory.

I don't know what the problem is

  • Try all the contents of /sigmicron/elgg/elgg-1.7.12    in /sigmicron/elgg/ 

  • I think you unzipped the content of the Elgg archive into root/ instead of root/ So, by calling in your browser you only see the subdirectory. You should move everything in root/ one directorylevel higher.

  • @IIOnly:
    LOLZ !!! ;-P
    You're just re-phrasing what I said succintly a few hours back ?


  • So do I put the folders: account, actions, engine, mod directly into sigmicron_elgg? Or do I need to put each individual file (ex: forgotten password, register etc) in the directory sigmicron_elgg?

    I want the main page to be the Elgg software so shouldn't I put it in the root directory instead of root/

    I'm sorry I don't really get it

  • If you want your site visitors to get to the Elgg site when calling you need to unzip the files in the Elgg zip archive directly to the root folder on your server. This means there shouldn't be a single folder called elgg-1.7.12 in your root directory after unzipping but the content (e.g. the folders acount, engine and the files like index.php, install.php etc.). If you have unzipped the package correctly, the installation should start when you call

  • I think I did exactly what you said but it's not working. I uploaded all of the directories and files from elgg-1.7.12 individually in the root directory but its still not working.

    Maybe it has something to do with the mySQL database. I created a database on Dreamhost called sigmicron_elgg. I don't understand anything about MySQL but maybe that has something to do with why it isn't working?

  • You still haven't copied/unzipped the files to the correct locations. When I call your domain I get the error

    Warning: require_once(/home/sigmicron/ [function.require-once]: failed to open stream: No such file or directory in /home/sigmicron/ on line 13

    Fatal error: require_once() [function.require]: Failed opening required '/home/sigmicron/' (include_path='.:/usr/local/lib/php:/usr/local/php5/lib/pear') in /home/sigmicron/ on line 13

    The directory structure that is included in the Elgg zip archive needs to be there in /home/sigmicron/ for the installation to start. This has nothing to do with the mysql database (the name and other details about the database are to be entered during installation).

  • I figured out why it is messing up.

    When I installed the directories some of the files/directories in them did not install. I don't know why some did not install. I used a Java uploading applet on Dreamhost to upload the directories. How can I make sure when I install the directories/files that all the contents get installed? I started to go through each individual file but so far there is a lot. It could take a while and I could accidently miss one. Is there a solution to just install all the files in the first place?

  • I have been going through every file/directory in Elgg comparing the folder downloaded on my computer to the FTP directories/files. I am in the middle of comparing the directory "mod" but I am stopping for the night. Let me know if there is an easier solution.

  • Isn't it possible for you to simply upload the zip archive and unzip it on your server directly?