New 1.8 install in Directory

I've uploaded elgg 1.8 into a dirctory /you/ in my root-directory but get this error message

 

We think your server is running the Apache web server.

The rewrite test failed and the most likely cause is that AllowOverride is not set to All for Elgg's directory. This prevents Apache from processing the .htaccess file which contains the rewrite rules.

A less likely cause is Apache is configured with an alias for your Elgg directory and you need to set the RewriteBase in your .htaccess. There are further instructions in the .htaccess file in your Elgg directory.

 

Have changed .htaccess to...

RewriteBase /
RewriteBase /you/
RewriteBase /public_html/you/
RewriteBase /mydomain.com/public_html/you/
RewriteBase /sites/mydomain.com/public_html/you/

but always get the error.

Any ideas what the cure is? My host support say they can't see any reason for the error.

  • Have you confirmed that AllowOverride is set to all?

  • I'm new to php and assume AllowOverride is in the .htaccess file.

    I've solved the problem by re-installing 1.7.10 and upgrading it to 1.8, works fine now.

    Thanks Evan

  • I have the same problem.

    I'm installing elgg 1.8 in my mac's localhost under a subdirectory (localhost/~Angelo/elgg1801/)

    Made sure mod_rewrite is enabled under httpd.conf and restarted apache

    And have this 

    <Directory />

    Options FollowSymLinks

    AllowOverride All

    Order allow,deny

    Allow from all

    </Directory>

     

    Also have an .htaccess (a copy of the .htaccess_dist) in the elgg1801 folder

    and added:

    RewriteBase /elgg1801/

     

    What else am I missing?