Bug with admin_gatekeeper() in Administration

Hello Guys,

I've got this Issue. Tried on two different webspace, but no chance, dont know how to fix that.

Fatal error: Call to undefined function admin_gatekeeper() in /home/www/web311/html/book/mod/tidypics/pages/admin.php on line 6

1) I uploaded tidypics in mod
2) activated it
3) It seems to run normally, but If I go to administration
4) click on tidypics administration, see the Settings tab
5) but if I try to switch to any other tab, i've got this Issue above.

Found same Issue in that Group, without Solution:

Used Google for hours. Please help.


  • Post your test elgg site url here (or pm to me if private) - i have one little test-check - i can do quickly -- and that will tell heaps !

  • I deleted tidypic 1.6.8 and installed DhrupDeScoop's tidypic 1.7.2. I continue to get the admin_gatekeeper error message. Also, with 1.7.2 all pictures disappear from all albums. Pictures are accessible but no longer included in the albums.

    After the 1.7.2 install, I ran upgrade.php. I cleared all cache, everywhere, I even tried a fresh browser. When I installed 1.7.0, the admin_gatekeeper error is gone, but the pictures are gone from the ablums, just like in 1.7.1 and 1.7.2.

    When I revert back to tidypics 1.6.8, everything returns to normal, including the pics are back in the albums.

  • @ RON In tidy picture administration settings there is a link to upgrade , I faced same thing when i moved to 1.7.1 from 1.6.8 upgrade script will show you right path please check it carefully it is not properly visible in links.

  • @ghurman THANK YOU. I'll seriously look in to that although when I select the settings from tidypic I get the admin_gatekeeper error message. But since I didn't get that error when upgrading to 1.7.0, I might be able to go that way and migrate into 1.7.1 (or 1.7.2 if I can eventually get that working which is suppose to fix the gatekeeper - although I noticed that the 1.7.2 is also suppose to be compatible with elgg 1.8 which sounds odd to me). I'll evaluate and reply back. Thanks again, I wasn't aware of the tidypic admin upgrade.

  • @ghurman Thanks again - One problem solved. I deleted 1.7.2 and installed 1.7.0. I then was able to execute admin setting (Change Tidypics Setting)  without the admin_gatekeeper error; and presto, something I never saw before. Right below the "Settings" tab, there is a link "upgrade". I selected it and now all my pictures are back in their albums.

    Now, to figure out why DhrupDeScoop's 1.7.2 still gives me the gatekeeper error. I've downloaded and installed it 3 times now, with no luck, but I'll give it one more try. Will report back.

  • The version 1.7.1 shows @ 1.7.2 because I was too lazy to change the manifest version tag ;)


  • OK, here's a strange one for yall. I deleted tidypics 1.7.0 (which worked well) and reinstalled DhrupDeScoop's 1.7.2 for the 4th time. I selected "Settings" from the tidypics plugin. I selected "Change Tidypics Settings". I get the admin_gatekeeper error. I tried cleaning all browser cache, turned off all elgg cache, selected "Change Tidypics Settings" (The url is http://mysite.com/cs/mod/tidypics/pages/admin.php) again. Still get the admin_gatekeeper error message. No matter what I try, I continue to get the error message. BUT WAIT ...

    When I select "Tidypics Administration" (The url is http://mysite.com/cs/pg/photos/admin/) from the leftbar Adminstration Menu, I DON'T get the error message.

    Two mysteries solved.

    1) I needed to run the tidypics upgrade to have the pictures appear in the albums.

    2) I needed to select Tidypics Adminstration from the Admininstration menu, not Change Tidypics Settings from the tidypics plugin.

    Thanks ghumanz and DhrupDeScoop for your help in getting me past this.


  • @DhrupDeScoop - You said "The version 1.7.1 shows @ 1.7.2 because I was too lazy to change the manifest version tag ;)" --

    Just be clear so others aren't confused, you mean the opposite, correct?

    "The version 1.7.2 shows 1.7.1...."

    Again, thanks for your help. It's very much appreciated. I owe you a beer or a dozen.

  • Do you mean clicking on this sucker ??

    tidypics settings

    Guess What ?!?!!! LOLZ LOLZ..
    Another creepy crawly ;-P dang ;-O
    Same cause of error as the one(s) fixed in 1.7.2 LOLZ ;-)
    Sometime today.. I will / might find the time to patch that too...
  • http://community.elgg.org/pg/plugins/release/764859/developer/Dhrup2000/tidypics-171-elgg-1710-fixes
    And yes - I meant the opposite -
    But I changed the manifest for 1.7.3 to say 1.7.3 and so Elgg will say so now.