Bug with admin_gatekeeper() in Administration

Hello Guys,

I've got this Issue. Tried on two different webspace, but no chance, dont know how to fix that.

Fatal error: Call to undefined function admin_gatekeeper() in /home/www/web311/html/book/mod/tidypics/pages/admin.php on line 6

1) I uploaded tidypics in mod
2) activated it
3) It seems to run normally, but If I go to administration
4) click on tidypics administration, see the Settings tab
5) but if I try to switch to any other tab, i've got this Issue above.

Found same Issue in that Group, without Solution:

Used Google for hours. Please help.


  • @DhrupDeScoop

    Did you fix it? I tried on myself, but didn't got it. Im not that PHP Genuie.

  • I have the code patches that work here.
    Not sure if I should release a corrected new version of TidyPics...

  • As I said above, when I deleted tidypic 1.7.1 and reinstalled 1.6.8, I continued to get the admin_gatekeeper error message.

    Next, I deleted 1.6.8 and installed 1.7.0. I still got the same error message. I then cleared ALL cache from browser and turned off simple cache, etc. Error goes away.

    But, my albums lost all pictures with 1.7.0. I could find the pictures, but there was no pictures in the albums.

    I deleted 1.7.0 and reinstalled 1.6.8. Everything is back to normal. No error message. Albums are back with all pictures attached.

    Back to using 1.6.8. I haven't had any luck with 1.7.x when I tested the beta a long time ago till now with 1.7.1.

  • hmm ;-) feel sorry for the situation ! while i see no problems, y'all havng these issues. kinda hard from here - to investigate without peeking over yr shoulders or poking directly into and/or debugging on yr server.. lose a lot of petinant info in just posting here because cannot 'see' what's really happening out there.. i've myself not ever had problems with ugrading, etc with plugins or elgg versions.. what can i say to help ?

  • DhrupDeScoop - just wave your magic wand and say "Presto." We'll all be fixed.

    I've found over the years, since elgg .8, that whenever I mention an error or bug, if I just sit tight, someone smart cookie looks into it, and then it gets fixed when I install a more recent version. With elgg 1.8 on the horizon, all plugins need rewrite, so for us it doesn't make sense to invest a lot of time trying to get something fixed that will be obsolete shortly anyhow. We'll just wait it out and test again someday day later. In any case, as usual, your help is always sincerely appreciated.

  • It would be nice if you upload your fix. As Files or Step-by-Step Version or new Version. I don't care, but anyways thanks for your help.

    Greets, Behnke 

  • http://community.elgg.org/pg/plugins/release/761414/developer/Dhrup2000/tidypics-171-elgg-1710-fixes

    Version 1.7.2 with my fixes

    @Ron - if yew still have problems - there's gotta be other issues on yr server / install..

    I could only investigate / fix via direct access to your Server / Elgg code.

    Might be something you're just overlooking that another set of eyes will catch quicker ;-o

  • @DhrupDeScoop - thanks for the fix. I'll try it out. fyi, it's not the first time we've blamed something on my installation and then shortly afterwards someone else finds the same problem and the developer fixes it; so I'm not ready to blame the server just yet. I could agree with a plugin incompatibility, which I will eventually investigate when I have time. If I get it working, I'll report back how, if not, I'll either wait for elgg 1.8 or give ya a hollar to look things over. At least this is only with my test site, haven't tried with production sites. Thanks.

  • @Ron,

    I tested on a fresh Elgg 1.7.10 + TidyPics 1.7.1  install :-

    • confirmed the reported error with Admin area

    Fixed the code to make TidyPics 1.7.2 and

    • error is fixed

    You are doing different logistics :-

    upgrade 1.6.8 => 1.7.x

    and you then get problems.. ;-(

    but when reverting to 1.6.8 'fixes' the problems -  something else may be wrong beyond the TidyPics - because - - the code is *correct in earlier versions < v.1.7.1 - and you're "reverting" from 1.7.x version(s).

    If there were database changes - e.g. private settings or metadata - introduced by v.1.7.x -- these would not be reverted by going to earlier versions...and "losing pictures" !

    So.. puzzling.. & moare puzzling..

    The way to investigate this could mean a fair bit of digging into the database, verifying code and maybe what I call 'down and dirty debugging inside the code" -- pretty much hoe I got that Admin thwangy discovered..



  • @DhrupDeScoop - I'll try your 1.7.2 sometime this week and see how it fairs.

    Why 1.6.8 has an album with a picture, but the 1.7.0 had an album with no picture attached is strange. The album came up, but it said, no images. I found the image, but it wasn't attached to the album. I only tested with one album with one picture. Before I try your 1.7.2, I'll add some more albums and some more pictures so it more realistic. fyi - I ran Case's dbvalidator, it didn't show any errors.