Bug with admin_gatekeeper() in Administration

Hello Guys,

I've got this Issue. Tried on two different webspace, but no chance, dont know how to fix that.

Fatal error: Call to undefined function admin_gatekeeper() in /home/www/web311/html/book/mod/tidypics/pages/admin.php on line 6

1) I uploaded tidypics in mod
2) activated it
3) It seems to run normally, but If I go to administration
4) click on tidypics administration, see the Settings tab
5) but if I try to switch to any other tab, i've got this Issue above.

Found same Issue in that Group, without Solution:

Used Google for hours. Please help.


  • Dear Developer,

    I've got an update. The path is WRONG. Dont know why. If I would click on a Tab in Adminmenu the Link would be: 

    and I got my Issue. 

    if I type manually:

    he show me the tab I wanted.


    Hope this is helpful to fix it,

    Regards Behnke 


  • I just tested that on Elgg.1.7.3 + TidyPics 1.7 (postioned at bottom of PugIns listing)
    -- and the admin tabs work OK
    But - /pg/tidypics/pages/admin.php?tab=xxxxx does not work ;(
    Wonder if you've run into some PlugIn conflict situation..

  • Im Running Elgg 1.7.10 and tidypics 1.7.1

    do you know where to change that path? Running through that PHP-Files and can't find it. Not an advanced programmer to get in that fast.

    It's not customized. Only installed Elgg with basic Plugins and tidypics.

  • OK ;-)
    I had TidyPics 1.7.0 - just moved to 1.7.1 on Elgg.1.7.10 and
    - - confirms the same error situation ;-P
    So.. it seems that TidyPics on Elgg.1.7.10 does have a **problem LOLZ ;-)
    I will post more if I find out what's causing that ;-o

  • @Behnke ;-)

    OKI ;-oO I got the code fix for TidyPics 1.7.1.. but I'm running out to get some pizzaaa ;-) So when I'm back - will post the code fix to patch that funny little BIG code error with TidyPics ;-O stay tuned !

  • I too installed tidypics 1.7.1 on elgg 1.7.10 and have the same problem. Something interesting. I deleted tidypics 1.7.1 and reinstalled tidypics 1.6.8 and now I get the same error. I did not get the error with tidypics 1.6.8 before installing 1.7.1.

  • @Ron - that should not happen - 1.7.1 code is the only version that has the fluky code - 1.7.0, 1.6.8 are both okay - i've checked code in both ;)

    try => delete the whole dang tidypics folder thang - upload 1.7.0 then try - shoud work - i tested that same sequence here at my xampp ;-oO


  • I deleted the whole 1.7.1 completely and replaced with 1.6.8.  It got the same error. It was working fine before I installed 1.7.1. Maybe something is stuck in cache. I'll try to clean mem and then try 1.7.0.

  • ahhh simplecache ? lolz maybe maybe.. b/c code is quite okiedoki..

  • first , sorry for my bad english .

     - remeber if you changed some thing in engine/start.php , or in engine/lib/ . 

     - if not , surelly you deleted some user from database , so use this plugin nommed "dbvalidate" for cleaning bugs in database . 

     - reward me if your probleme solved