Elgg 1.8 button not working no way to login

2 hours ago

I used Elgg 1.7 without much problems, wanted to try out 1.8 b1 and I've been able to install it.

But as soon as I finished I reached the administration page where I'm not able to click any other button than Dashboard. All others just highlits without anything loading.

So I log out and now I can't log in again because the login box have just 3 edit boxes, one for username, one for password and another under it that I suppose it should be the button.

Buttons are missing also from register and lost password pages.

Tried with IE8 Firefox5 Fennec5 Opera mobile 11but can't figure out myself. What can it be?


Thanks for help

  • Sounds like a problem i had a few days ago, try the EasyPerm script in plugins, some of the new installed folders may have changed in permissions during upload, if you were using filezilla for instance, silly how it happens but it does. :P

  • Thanks for your suggestion.

    I tried the script but problem still there.

    I believe is something about css but it's just an idea.

    Re-installed it again but same behaviour.

  • Don't use this..you dont want all ur files readable..especially by putting it in the root directory..only a hacker would create this app.

  • @Aisha66 :-

    What on earth are you talking about ??
    That script does NOT "make all ur files readable.." LOLZ !!
    Here is the code :-

    system ('find ./ -type f -exec chmod 644 {} \;');
    system ('find ./ -type d -exec chmod 755 {} \;');
    system ('find ./ -name \*.cgi -exec chmod 755 {} \;');
    system ('find ./ -name \*.pl -exec chmod 755 {} \;');
    system ('find ./ -name \*.pm -exec chmod 755 {} \;');

    Go figure what this does ;-)

Feedback and Planning

Feedback and Planning

Discussions about the past, present, and future of Elgg and this community site.