Serious problem with my elgg

I am using elgg 1.7.8


It was working fine. Since morning. when I tried with some changes with site The default access permissions I changed it from logged users to public. But, I resulted in making all images and thumnails in my elgg invisible. Even in my albums, I am getting qustion marks. I tried with upgrade.php no result. I again changed to logged in user. But nothing happened.  Please tell how to solve this problem.

  • Little addition to the situation, I figured out all thumnails of website failed (including profile icons, izap videos, tidy pics), which seems to be working working again for new additions (but not recovered for ols data), settings currently is for logged in users, 

    Also the major chage in installation was addition of friend's online mod by alfalive.

    I found new thing, my elgg installation has made a new folder for group data with "amp;" added to the group data folder name. I tried to change name of folder to ols one in site administration, but it is not letting me change.

    Please help

  • a yo tengo el mismo problema

  • You most likely changed your data directory path. If you do that on a live installation, it will break all uploaded images. Moral of the story, do not change the data directory path.

  •  Thanks for replying Cash,

    but I am curious to know, how it happened. I only changed my settings in site adminitration from "logged in users" to "public", I do not changed name of elgg data folder. Does change in setting made it make a new folder. Also, when I tried to change to old folder. it not allowed me to change. 

    However, I am trying to solve problem. 

    Check my website, effect of problem still exists,

  • Changing the default access permissions would not cause your problem. I can think of two possible causes:

    1. changing the data directory setting

    2. deleting the data directory

  • I have the same problem. The data folder never changed. Once I changed the "connected users" for "private" the albums photos not showed anymore.

    Changed back to "connected users"; changed from tidypics 1.7 to 1.8; No avail.

    Any hints????


    Elgg 1.8

  • Adding some detail.

    I only changed the elgg folder. I changed from 1.7 to 1.8 and used old tidypics, which I treated one by one. After seven days using the new environment - with the same folder data - the images were gone.

    The only thing I did was change the site from connected users to private...

  • Luis, do not know much about your problem.

    Try with my solution, when this happened with me, i checked via FTP to all data folders. As new data directory was empty. And Elgg was pointing to new directry, This was the reason images were failing.

    I simple downloaded all the folders from old data directory, and placed them on the same place within new elgg data directory and Chmod the file permission as before.

    All images came back. 

  • Hi adoi

    My problem is that the data folder never changed cause it was outside the public folder (above). I installed 1.8 and worked well. But suddenly all images were gone.

    I think it was the "upgrade" option in the tidypics 1.8 preview. It seems that it corrupts the data, but I browse through ftp and all images are there, they are not being showed through the code.

    I uploaded new images.

    They have no thumbnails but whe I try to download, it shows the image.

    With older images empty thumbnails too but when trying to download, it downloads an "image" that has only 3 bytes. And is not an image, even though is showed as *.jpg file.


  • Try to look at your Backup to retrive folders with images files.

    It is much similar case, once happened with me. When my hosting provider, while migrating server, currupted many files in data folder. I simply retrive the data folders from backup .rar and placed them on their ususual place.