Site Domain Move

Okay, this is puzzling me. Today I moved my site - only a domain name change, not server->server. So, same IP, same DB, the only thing changed is the site address.

Almost everything is perfectly fine... except for some reason whenever I load the site, my browser tries to look up the old domain (which is no longer accessible, because the nameserver isn't online at the moment).

But there's no mention of the old domain in the DB except in elgg_users_sessions and no html references whatsoever.

I've tried clearing the cache in the browser, trying a browser which I've never visited the site with before, etc etc, all with the same result: it loads the page fine, but tries to look up the old domain name.

The only other symptom is that vazco's topbar doesn't load properly (but there are no references to the old domain name there, either, which is slightly confusing!).

Ergh? Anyone have any ideas? Never had this last time when I moved from -> to, so it seems a bit weird.

Address of the site is if anyone wants to go peek and see the issue in action.

  • Meeeeh.

    Being suspicious because vazco_topbar wasn't working right (and since no users are accessing the site right now anyway), I thought I'd try turning vazco_topbar and vazco_topbar_template off.

    And now my site only displays a grey screen. D: Ran the upgrade.php script but no change.

    Any way to turn a plugin on with a quick edit of the database?

  • Aha!

    For future reference to anyone who comes along this way later: the issue was one of permissions, specifically permissions for the datastore directory. :)