elgg installation need help

I cant get my elgg 1.78 to install
Ive followed the troubleshooting but am not an expert
I have AllowOveride All in httpd.conf which is loading:

LoadModule auth_basic_module modules/mod_auth_basic.so
LoadModule auth_digest_module modules/mod_auth_digest.so
LoadModule authn_file_module modules/mod_authn_file.so
LoadModule authn_alias_module modules/mod_authn_alias.so
LoadModule authn_anon_module modules/mod_authn_anon.so
LoadModule authn_dbm_module modules/mod_authn_dbm.so
LoadModule authn_default_module modules/mod_authn_default.so
LoadModule authz_host_module modules/mod_authz_host.so
LoadModule authz_user_module modules/mod_authz_user.so
LoadModule authz_owner_module modules/mod_authz_owner.so
LoadModule authz_groupfile_module modules/mod_authz_groupfile.so
LoadModule authz_dbm_module modules/mod_authz_dbm.so
LoadModule authz_default_module modules/mod_authz_default.so
LoadModule ldap_module modules/mod_ldap.so
LoadModule authnz_ldap_module modules/mod_authnz_ldap.so
LoadModule include_module modules/mod_include.so
LoadModule log_config_module modules/mod_log_config.so
LoadModule logio_module modules/mod_logio.so
LoadModule env_module modules/mod_env.so
LoadModule ext_filter_module modules/mod_ext_filter.so
LoadModule mime_magic_module modules/mod_mime_magic.so
LoadModule expires_module modules/mod_expires.so
LoadModule deflate_module modules/mod_deflate.so
LoadModule headers_module modules/mod_headers.so
LoadModule usertrack_module modules/mod_usertrack.so
LoadModule setenvif_module modules/mod_setenvif.so
LoadModule mime_module modules/mod_mime.so
LoadModule dav_module modules/mod_dav.so
LoadModule status_module modules/mod_status.so
LoadModule autoindex_module modules/mod_autoindex.so
LoadModule info_module modules/mod_info.so
LoadModule dav_fs_module modules/mod_dav_fs.so
LoadModule vhost_alias_module modules/mod_vhost_alias.so
LoadModule negotiation_module modules/mod_negotiation.so
LoadModule dir_module modules/mod_dir.so
LoadModule actions_module modules/mod_actions.so
LoadModule speling_module modules/mod_speling.so
LoadModule userdir_module modules/mod_userdir.so
LoadModule alias_module modules/mod_alias.so
LoadModule rewrite_module modules/mod_rewrite.so
LoadModule proxy_module modules/mod_proxy.so
LoadModule proxy_balancer_module modules/mod_proxy_balancer.so
LoadModule proxy_ftp_module modules/mod_proxy_ftp.so
LoadModule proxy_http_module modules/mod_proxy_http.so
LoadModule proxy_connect_module modules/mod_proxy_connect.so
LoadModule cache_module modules/mod_cache.so
LoadModule suexec_module modules/mod_suexec.so
LoadModule disk_cache_module modules/mod_disk_cache.so
LoadModule file_cache_module modules/mod_file_cache.so
LoadModule mem_cache_module modules/mod_mem_cache.so
LoadModule php5_module modules/libphp5.so
#LoadModule cgi_module modules/mod_cgi.so
LoadModule version_module modules/mod_version.so

Do i have to uncomment suexec module too?
I have .htaccess mod_rewrite enabled
I have safe mode and register globals off in php.ini
My database is installed correctly and i can access it in phpmyadmin
PHP Version => 5.3.6 System
MySQL 5.1.56
Cent0S 5.5 final with TurboPanel/simple control panel
My elgg is in /home/john/public_html/
My data folder is in /home/john/
Permissions are set

My server url points to an index page with the folder elgg showing, i go into it and find the settings form which tells me the database is installed correctly. When i fillout the settings form i get an oops firefox couldnt load for some reason error which isnt very informative despite me turning errors on.
Its the same error i get when i go to http://serverurl/home/john/public_html/phpinfo.php where i put a phpinfo file.

Can someone tell me what im doing wrong? Or offer any debugging tips? Im deflated that i cant getit to work after a few weeks of trying on and off, and dont think i could stomach the suggestion of start from scratch.

  • This firefox error i also get when i did not have the php5 module loading. But its a generic error so i dont know what it means. How do i get more specific errors? In a log? Which one?
    I have an ssl certificate installed for the site that i want to use elgg for, which is where my elgg is in, "john". I think its installed correctly. I get the settings error too despite turning off enable ssl on the form.

  • Hi jskye,

    The fact that you can't even get a basic phpinfo file to display suggests that this problem is server-related rather than Elgg-related.

    Have you asked your hosting provider for help?

    It is common by the way for the URL for:


    to be


    or even


    Have you tried those?

  • thanks kevin, as i said im no expert
    and i dont know why i cant get the basic info file to display, the instructions i followed were quite basic
    I also read it should load wherever on the server it is, but i will try your suggestions in the morning.

    yes i am new to linux systems and the web in general but have learnt alot already and am trying to learn more. but sofar as i know ive followed the instructions.
    could you tell me if i should need to disable/uncomment the suexec module?
    i will also seek help from GoDaddy

  • i discovered that i spoke to soon regarding the phpinfo.php script
    it reads it when i have it on the same level as the elgg folder   /home/john/public_html/
    as i have the rewrite base as /home/john/public_html/
    so it reads it when i go to https://serverurl/phpinfo.php
    and when i put it a level above public_html it is obvo now above the rewrite base

    But i also found the error in the apache error log is
    File does not exist: /home/gymair/public_html/home
    That is, the one time settings file that's already under home is now looking to write to home i think
    i assume its doing this when i input the paths to the site and data folder
    maybe my solution is to not have a rewrite base but to get to the settings file via the path to it on the server and then define the settings
    but im tired and confused right now and will try that in the morning
    (ps. the phpinfo file showed that the things im meant to have running are running)

  • Scanned over your posts here. It looks like a mod-rewrite issue. You said you ran the web installer, entered the database credentials (and it worked), then entered the site details and got an error message. That generally means a mod-rewrite problem.

    Elgg 1.8 will automatically check that for you but we haven't released the beta version of that yet.

  • thanks cash

    well i still havent gotten elgg to work
    i tried using a nightly build from about a week ago and using that install i get through the install and even add the first user but then i get a 404 error when im directed to activity

    GET /elgg/activity HTTP/1.1" 404 338 "http://www.website.com/elgg/install.php?step=settings"

    This seems to be the furthest ive got in installing elgg yet
    So my main question is whether you know whats happening with that error and when the stable release of 1.8 will be out?

    As an aside apache question, im just wondering out of curiosity (as i have another site on my server that can run in cgi mode), where elgg loads or doesnt load mod_cgi? I know that apache loads the module in http.conf but doesnt this mean that apache is now just able to be run in cgi? so what im asking is it possible to run two /user/public_html sites , one with apache in cgi and one without on the same server? if so, what implements it at the user level or is it only possible to run apache as one of these only.
    Im currently running my other site without cgi anyhow (that is, ive commented out the mod_cgi in httpd) and it works fine but i ask in case i wish to try to run both if possible later, as an installation i use on this one recommends to be run in cgi mode.
    So i guess what im asking is, can i disable mod_cgi at the user level not the apache level or is it one or the other in http.conf?

  • I assume you have your "Elgg root directory" on your server in the path


    If you still get the same error it's due to a wrong entry on the settings page during installation (Elgg can't resolve the site URL correctly).

    Your site URL is not




    You need to adjust this entry during installation. You also need to start the installation with a new and empty database in case you have previously entered a wrong site URL or path as Elgg (1.7.X) doesn't take any changed input if there have been entered (wrong) entries during a previous installation attempt.

    Right now I don't think you have a mod_rewrite problem. Also, if "AllowOverride all" is in your http.conf for the directory /home/john/public_html/ it's correct.

    You should also set

    RewriteBase /~john/

    in Elgg's .htaccess. Then it should work.