Upgrading TinyMCE plugin?

The TinyMCE version included in the core tinymce plugin is about 2 years old already. On a quick shot I've downloaded the most recent TinyMCE version and just replaced the tinymce subfolder with the new version. Everything seems to work fine - on a test installation only so far.

Does anyone has any experience yet with more recent versions of TinyMCE? Is it really so simple to upgrade it or are there any culprits to expect?

In case anyone wonders why to upgrade the TinyMCE editor might be necessary: first, it hopefully solves the issue with copy+paste from MSOffice introducing some unwanted text. Secondly, IE9 seems to have some serious problems with the TinyMCE version used in Elgg.