Error: "Form is missing __token or __ts fields" on many plugins

I have seen this error on most of embed video/gallery and Tidypics. It looks to me they are having things to do with 1.7.7 core which requires previous version plugin add some code to fit the core requirement. They owners of the outdated plugins seems do not have time to do the update. 

Will someone give a clue on how to fix?

Any suggestions are greatly appreciated.

Jimmy