Big problem for a noob!

Hey peeps, I got a big problem but have no clue how to fix it.... Every time i keep installing (some) plugins i and try to edit there settings it comes up with a White page and this writing: A file permissions error has occurred. Please check the permissions on the script and the directory it is in and try again.


Please help im stuck! 


  • If it only happens when installing 3rd party plugins and it happens regardless what plugin you are installing, I believe you are doing something wrong when moving the files to the server or extracting them there. Check the permissions and ownership of the plugin files. You can compare them with the settings of the core plugins and adjust them accordingly.

  • right i have tried to install elgg 1.7.6 from scratch but still get the same stupid error! 

    I have contacted support and see what they say :)

  • sorry to be a pain.... what permission code do plugins need?

  • No code but permissions settings (read, write, execute/access) of files and directories:

    File permissions should be set to 644 and directory permissions to 755. Granting too much permissions can also result in problems as your server might be configured to block execution of scripts for security reasons if they have too much permissions set (e.g. 755 for files).

    Some plugins' files might have set been published here with too much permissions set before packing the archive file. Another reason for permission problems is extracting archives in Windows before copying the files to the server, because Windows doesn't know anything about Unix file permissions.

    Depending on your Apache configuration (in case of DSO php handler) you might also need to adjust the owner and group of the files and directories.

  • thanks iionly! that helped loads :)