Google Chrome problems with elgg


I just found about elgg yesterday. I consider myself fortunate to have found such a treasure.

I'm glad that I have joined your friendly community. Thank you for allowing me in.

I would like to share with you a problem that I have noticed when using Google Chrome browser in ubuntu system.

I failed to install elgg through Chrome for  linux. I'm not sure what the problem is, but somehow when you try to install, elgg coundn't connect to the database and so no tables get created.

As soon as I used Firefox for linux, elgg installed without any problems.

The same happened when I tried to join your community here. Chrome failed to do it, and gave me this error:


Oops! Google Chrome could not connect to

When I tried Forefox, it completed the join process flawlessly.

I hope this little piece of info helps someone with similar situations. Not sure if all Chrome versions have the same issues, but mine is Chrome 8, linux version (ubuntu)


  • i have seen my site present with the 'could not connect to database' a few times without any explanation as to why - it works mostly though..

    i am using chromium (open source version of chrome) on ubuntu too.

    i don't have much more to add, other than that it could be something to do with https, though i'm not sure.

  • Quite interesting topic. I installed under Kubuntu with Chrome with no problems.

    Rodolfo Hernandez

    Arvixe/Elgg Community Liaison

  • I've found this..

    The focal filesystem, referenced by file://, is treated as a hostile Cross-Site Scripting (XSS) environment. AJAX now entirely fails on Google Chrome, with urls starting with "file://". There are two different ways to get around this problem:

    • Launch Google Chrome with the additional parameter --allow-file-access-from-files (or --disable-web-security, if you want to be rude), e.g.
      google-chrome --allow-file-access-from-files
      Or you start up a web server on your local system, and use
  • Hello,

    Maybe there's a simple explanation to my pb but I couldn't find it when I searched the community. 

    I just installed Elgg (Release - 1.7.3, Version - 2010071002).

    I try to log in (as admin) with google Chrome. It runs ok and I get the "green" message : You are now logged In.

    But When I click anywhere, I get disconnected. Same thing with the "remember me" option.

    Any idea?

    Thanks for your help.

    + I have another strange problem (any connection with the first?), I ceated the DATA folder with chmod 775 via SFTP. Placed it like that : xxx/data/ and xxx/elgg. But soon after the (smooth) install, my "2011" DATA subfolder is now chmod 700. And now I can't access the folder and I can't change the chmod back to 770.

  • Elgg creates things under the data folder with limited permissions. There is a plugin on the community site for viewing files in your data folder: link.