Upgraded to 1.7.6 and River DashBoard Not Functioning

Hello Folks,

I've recently upgraded from Elgg 1.7.1 to 1.7.6

There are few problems but the biggest one that I need to deal with right now is the fact that the RiverDashBoard is not functioning.

I am using the Core RiverDashBoard plugin that came bundled with 1.7.6 and all I get is a white screen with some text on it. 

I've tried deleting the folder and re-uploading it and clearing my cache but to no avail.

I've basically disabled any non-core plugin to see if there was some conflict and this has not helped.

Any ideas would be great.

Thanks in advance.

  • Did you follow all of the instructions in UPGRADE.txt?

  • Yes, I followed these instructions:

    1. Overwrite your existing Elgg files. Any modifications should have been written within plugins, so that they are not lost on overwriting. If this is not the case, take care to maintain your modifications.
    2. Visit http://your-elgg-site-URL/upgrade.php
    3. Copy htaccess_dist to .htaccess, replacing your existing version. If you modified the default .htaccess, be sure to move your modifications over to the new one.
  • The only thing that I can think of is that perhaps I didn't disable the RiverDashBoard when I did the upgrade and that the RiverDashBoard I was using was actually the RiverDashBoard+Wire pluggin.

    Perhaps something was changed during this process.

    Can anyone suggest a way to proceed.

    My site is essentially useless without the RiverDashBoard pluggin.

  • Which other plugins do you use? Is custom_index among them?

  • Yes, I am using Custom_Index and that has been a problem as well.

    There seems to be a conflict with Custom_Index and the old version of Izap Video.

    It was causing a kind of 'double image' in the front page of my site when Custom_Index was activated.

    I have since deactivated Izap Video and Custom_Index is operating normally.

    However, RiverDashBoard is still not functioning.

  • I think custom_index is your problem. Out of the box it will not display the dashboard. I remember changing its index.php.

    After activation i added:

    if (isloggedin()) {

    Right behind the require_once line. That did the trick.

    Gerrit Venema
    Gol Gol Community

  • Gerrit,

    Thanks for your reply.

    I don't quite understand though.

    Since the both the 'RiverDashBoard' and 'Custom_Index' are core plugins for Elgg 1.7.6, doesn't that mean that they should be compatible?

    In Elgg 1.7.1 both of these plugins worked well together with no conflict.

    Has something changed in the recent releases?

    Also, when I disable the Custom_Index plugin, the RiverDashBoard pluggin still gives me a white screen with unformated text on it.

    Perhaps there is something I don't understand.

  • On the installation process, did you disable all plugins before upgrading?

    Are you using another plugin? Because I just made a test install, with the custom riverdashboard and had no problems with it.

    Rodolfo Hernandez
    Arvixe/Elgg Community Liaison

  • Started with 1.7.5 myself. I checked back in the repository but it seems this file was pretty much the same since it started apart from internal renaming/updating of core functions. River dashboard worked immediately, I only had trouble getting at it with custom_index. There is a comment that custom_index is deprecated by sitepages anyway.

    Maybe you could setup your PHP error log and crank up the debug setting in your site settings to see what is wrong with your river.

    If your views cache is out of date then just save site settings (with or without changes) and Elgg should rebuild the views cache. Only thing is that activating a plugin should trigger this also. To see if the view filepath cache has anything to do with it you could turn it off in site settings.