Elgg on PHP 5.1.6

Hi to all,

I would like to install Elgg on a server that just upgraded their PHP version to 5.1.6. I noticed that the requirements state PHP 5.2 minimum and I am wondering if it will install and if I will miss any major functionality with 5.1.6.

The server guys told me that 5.1.6 is the highest that they can support so 5.2 is not an option for me. Does anyone know the difference between the two PHP versions?

Thanks,

Charles