Deprecated in 1.7: extend_view() was deprecated by elgg_extend_view()!

Hi everyone.

I'm getting this error on my elgg install :

Deprecated in 1.7: extend_view() was deprecated by elgg_extend_view()!

 

It can appear while posting, or even refreshing, but not always. The site worked like 3 monthes without having this once, and now this error message pop sometimes.

Can someone help me ?

group:replies

  • By pradacaca

    Here's tyhe origin of the error message : 

    engine/lib/views.php

     

     

    00958 function extend_view($view, $view_name, $priority = 501, $viewtype = '') {
    00959     elgg_deprecated_notice('extend_view() was deprecated by elgg_extend_view()!', 1.7);
    00960     elgg_extend_view($view, $view_name, $priority, $viewtype);

     

    But what does it mean ? How can I solve it ?

  • By Brett

    It means you're using a plugin that hasn't been updated to the latest functions.  Where is this message showing up and what version of Elgg are you using?  If you have debug enabled, it will log which file is calling extend_view() instead of elgg_extend_view().

  • By pradacaca

    I'm using 1.7.5, but a plugin might be out of date...

    The message is showing in the ajox pop ups (like you comment has been posted, etc...)

    Is it safe to enable debbug ?

  • By Brett

    That error shouldn't be showing up in a javascript popup until 1.8, so there might be a bug in Elgg core.

    If you enable debug it will write to a debug log.  Its location depends upon your server setup.  It's safe, but unless you know where to look it might not be useful.  It could write either to a PHP specific log, or to an apache log, so be sure to check both.

  • By pradacaca

    Here it is :

    image

    So, if I find the plugin, I just might update it ? or rename the function ?

  • We've had no reports of this so I doubt it is a core issue. You could try turning off plugins until the problem goes away.

  • By pradacaca

    So I checks the start.php of all my plugins, et no one still uses extend_view.

    But this morning I got   Deprecated in 1.7: extend_view() was deprecated by elgg_extend_view()!

     

    So I was wondering, can this fontion be located elsewhere than in start.php ?

  • By Per Jensen

    Yes. If your editor has a search function, it's easy to find "extend_view(".

  • By pradacaca

    it's only in plugins right ?

    Is the a way to avoid doing this to all php files one by one ?

  • By Brett

    @pradacaca - I just noticed there are commas in the version number.  This makes me think there might be a locale issue where 1.7 and 1,7 are being compared as strings instead of ints.  What locale are you using?  Put this in a file and run it from your server, then link me or C&P the results:

    var_dump(setlocale(LC_ALL, null));

    var_dump(setlocale(LC_NUMERIC, null));

    var_dump(localeconv());

You must log in to post replies.