elgg spam issue solved

I was having very bad time with spam on my Live elgg site. All spam was posted on messageboard and messages . I tried each and everything but nothing helped. So I made my mind to kill those guys PERMANENTLY . I checked server Logs . All spammers were coming from two ip Ranges starting from 41 and 196 . So i made few changes to my .htaccess file that Killed them all.


I just added following lines at the end of my .htaccess file

order allow,deny
Deny from
Deny from
allow from all

from last three weeks No Spam Messages at all . I want other people who are suffering from same issue to try my solution. If it works or not post your comments


  • @Daljit: This banned the particular range of IPs to visit on your site. All users under your denying range of IP won't be able to browse your site. This could be temporary solution. We have a plugin "izap-antispam" at http://www.pluginlotto.com. This really helps http://www.pluginlotto.com to keep such frequent posters away from our site.
    What i believe, these are background programs posting frequent contents on different elgg sites. So we stopped such programs with our program :)

  • i just delete my spammers, no ip bans or anything, been doing fine since then.

  • I deleted them too. It is a better solution to use recaptcha plugin.

  • i got to know that Firewall helps a lot. i also turned firewall on that is also good. Plz see and make sure you have firewall on


  • i have recaptcha enabled and still have had 2 spammers sign up even though the site is not in use or being advertised anywhere.

  • @tunist Recaptcha will stop bot spammers, not human spammers. 

  • The WAR ON SPAM is like the WAR On TERROR... It may never be solved or will NEVER END. All you can do is... (Famous Words)

    Hope for the BEST... Prepare for the Worst

    (Obama's next words haha!)

  • Ok I am going to run an Experiment on sort of a TEST Site that is going to be launched soon. I am going to use the Robots Meta Tag: NoFollow from using the Metatag_Manager plugin that is on here. It has a Global Site Setting for the Robots Meta Tag where normally it would be filled in with: index, follow. I have been looking up and reading several things from Google and others about the rel=NoFollow. One thing is I have no idea how to put into any of the plugins. Plugins that should be NoFollow patched are: blog, bookmarks, thewire, files, pages and profile (could be more). So the easiest way possible is to go all the way and change in Metatag_Manager: index, nofollow. This will then place the Nofollow Meta Tag on ALL Pages in the entire Elgg Install. I plan to run this as long as I can and to see if either the Indexing of this Brand New Domain still works and also what I read is possible damage to Page Rank I will see if this new domain stays stuck at Page Rank 0.

    I will report all my findings on here and also monitor if any spam accounts are ever created.

  • So far the new site domain which is MeConfess.com has been indexed by Google just fine and it has the NoFollow Meta Tag