Anyone availible to help and maybe explain token issues with a plugin?

I Have brought and paid for Vazco Mainpage but the guy who runs it doesnt seem to be too helpful just a reply would be nice!

Im running the latest elgg and vazco mainpage and theres a latest images widget on the main page the problem is I run a photographers related website and to get more members it would be helpful for unregistered users to see the latest images uploaded to site that are "public" the problem is theres just empty placeholders unless your logged in someone suggested it was a token issue so would like to know if anyone can help sort this for me, Im not great at php but I'm capable of editing php and some modifications etc (I mainly don't know how the whole php works but can edit)

If anyone can help please let me know to see the problem go to

  • LOLZ ;-) Looks like you just met my old "friend' Mikhal... The latest version of that PlugIn should be compatible with Elggv.1.7.x Your problem is most likely to do with site access permissions - if the "empty place-holders" are a BIG "?" ;-(

  • Check you PMs here at the site. ;)

  • DhrupDeScoop its not, and we've been discussing this over at but no feedback not even an "I'll look into this" comment

    The placeholders are nothing just tiny placeholders with Image in them... nothing else!

  • But if its public it should show logged in or out!! apparently its worked before and Im not the only one thats having a problem now!

  • Listen to the man ;-)

    <div class="messages_error">
    <span class="closeMessages"><a href="#">click to dismiss</a></span>
    <p>You must be logged in to view that page.</p>
  • Im listening... all images are set to PUBLIC and this guy has the same problem posted on -> thanks for the update to 3.0; some issues are resolved. :)

    the remaining ones here that I have seen are:

    i) the tag cumulus plugin still displays only a few tags by default - corrected by changing the function call in the widget code.

    ii) the tidypics image widget is still showing empty image thumbnail place holders.. the target url for these images does point to the right images.. the links work correctly.. but the thumbnails do not appear unless i am logged in.

  • plus the whole reason for the mainpage mod is surely for a more welcoming homepage for possible new users meaning they won't be signed in anyway so why create a widget that doesn't work?

  • 'this guy' = me.. ;P

    i haven't investigated this bug yet as i have been focussing on other issues and i figured vazco would fix it.

    i'll have a look now though

  • @djSupport:

    sorry to hear that it didn't work out yet with the changes from my site. Actually, I had this problem after login with access set to logged in. I thought the changes might also help in your case as they solved my issue.

    Have you turned on caching in vazco_mainpage? I'm not sure if the mainpage cache gets updated also when enabling/disabling the plugin. You should go to the mainpage widget settings page and to click on "Save" there. Then the mainpage cache gets updated for sure. Maybe the changes only take effect then.