elgg versions / MySql compatibility

Will elgg 1.7.4 work with a MySqul database originally created to run with elgg 1.7.3?

Alternatively, how to upgrade 1.7.3 to 1.7.4? Is there any ptach?