server goes to it's error page

I have completed the steps for installation up to the page requesting System settings. I fill that in, click on SAVE and it goes off to my server but gives me an error default page. My server host says that it is a coding error.

Site URl data:

Directory path:

View: default

I have tried deleting the "install.php" and also resetting the permissions on the Data and Public_html directories (now back with full permissions) to no avail.

Nothing is being written to the Data directory

Can anybody help please?

  • The site URL should most likely be only:

    The path to the root directory: /home/a9472337/public_html/

    and the path to the data directory: /home/a9472337/data/

    Elgg can't resolve aliases defined in Apache and therefore guesses the site URL wrong sometimes.

    As the site URL and paths are saved in the database during installation you most likely have to drop your database and create a new one to start with the installation again.

  • Thanks iionly. Tried that but still getting the error page. Also nothing being written into the Data directory

  • During installation there's nothing written to the data directory yet. At least I think that not even a directory for the admin account is created yet - but as I understand you haven't reached this next step during installation yet.

    Did you copy the Elgg files directely into your public_html folder or into a subdirectory in this folder? I assume you copied them directly into public_html.

    Maybe you could edit .htaccess and remove the # in the line

    # RewriteBase /

    And again you most likely have to begin with a fresh database.

  • All ellg files were ftp'd directly to the public_html directory.

    How do I restart the database? everytime I have looked at that I have deleted all files and directories and ftp'd again from scratch - very time consuming. If the database you refer to is data written to the Data directory, nothing atall has been written there. The Directory is completely empty.

    Will have a look at removing the #


  • I mean the mysql database. How to delete and re-create it depends on how you did it the first time (CPanel, phpMyAdmin or some other way?). You did create a database, didn't you? The database files are not written to the data directory. The location of the database directory depends on your server, for example it could be saved in /usr/lib/mysql/. It's also not necessary to delete the Elgg files and create them again. Just delete the mysql database and create a new and empty database with the same name, admin user account and password and the values in settings.php will fit.

  • Thanks iionly, yes I know about the mysql, but I was expecting data to be written to the data directory that I had created. I tried removing the # from .htaccess but it didn't make any difference. I will recreate the mysql database and go from there. Thanks for all of your help. This 75 year old brain takes a bit of winding up at times

  • 1)    Who is your host ?

    2)    What sort of Plan do you have ?

    3)    "..expecting data to be written to the data directory.." does not compute

    4)    Data Folder IS NOT the SAME AS DATABASE

    5)    Try to post your "error default page" screenshot somewhere -> then maybe we know what error is.



  • Hi Dhrup


    2: Free site hosting

    3: As the ellg installations advised to create a Data directory outside of the public_html directory and to establish 777 permissions, I expected data to be written there.

    4 I realise now that Data is not Database

    5 I have left install.php in place at : The data that I have been filling in is:

    Site email:

    Site URL:

    path to root: /home/a9472337/public_html/

    path to data: /home/a9472337/data/

    The error page is just a default page of the webhost server

    I would appreciate your accessing my

    I've got no more hair to pull out

  • Unfortunately, deleting and recreating the database is a MUST when you made any mistake while entering the values for site URL, path to root or path to data directory (yes, you could change these values also directly in the database but it might be even more difficult for beginners to do that). Even when you are asked again to enter the details of your site in case the installation hangs at this stage, these new values seem not to be used but still the wrong values in the database... therefore, try to recreate a new database before you try to change anything in .htaccess or try to enter new values during installation as it will be fruitless.

    The Elgg data directory is used mainly for saving uploaded content later (for example profile pictures, uploaded files or pictures or videos). During installation nothing is written to the data directory yet. A lot of content (for example blog text, comments etc.) is also not saved in the data directory but also in the mysql database. Try to finish the installation of Elgg properly first. After you have finished the installation and created an admin account, maybe also uploaded a profile picture for the admin account, you will see the user directory structure beginning to build up with this account. Also, when activating the caching mechanisms of Elgg (simple cache and filepath cache) you will see the cached files saved in the data directory.

  • I queried the default with the web host and they advised that it was a code error

    I have recreated the mysql data base 15 minutes ago and am getting the same result