Group icons

I am running into this problem and I can't seem to get my head around it. Whenever I edit my group details and try to to change the icon image it shows only a white picture (or empty file when trying to download the file).

I checked the following:
- GD library is enabled in php with support for .jpg, .gif and .png
- the image I'm trying to set as icon is a small .png
- profile icon creation does work and I can create an avatar with the same .png image
- captcha doesn't create an image

The error log shows no errors when I press the save-button when trying to save the group.

Does anybody have any idea what could be the problem?

Kind regards,

Matthijs

  • Does it work for other image types? Can you upload a jpg for the group icon?

  • Nope, I tried jpg, png and gif's. The thumbnails do get created, because I can see them in my data folder. I can also download them and open them and they are all in good order. So I'm a bit puzzled. It so sounds like a server side error because profile pictures, work but captcha and group icons don't. But I don;t know what the main difference is between the two. I was thinking accession rights to the data folder, but why would my profile pictures work then and not the group icons?

  • Found out it wasn't working due to an additional carriage return created in the start.php file from one of my plugins. Disabled all non-core plugins and it worked again.