missing and odd tabs (izap_videos)

I just installed the 3.7b version of izap_videos, and I'm eager to use the improved plugin!

So far I've seen a couple of problems, though. First, the text on the three tabs (on server, off server, and embed) on the page to add new video reads: 

 

 

Huh? Shouldn't this display simpler menu items?

Second, I see no tab for server analysis on the Administration > Video settings page. Just a single tab, "Settings." 

NOTE: I'm currently running Elgg 1.6.1. I could update to 1.6.2 (or 1.6.3) if you think it may fix these issues, but I wanted to check first since I'm worried trying to upgrade will break other things.

Thanks!

  • I don't know if your problem is caused by using Elgg 1.6.1 and if it would help to upgrade to 1.6.3. I had used izap_videos 3.7b shortly on Elgg 1.6.3 without problems before upgrading to Elgg 1.7.3. As Elgg 1.6.3 is mainly a security upgrade it might be good to upgrade just to fix security issues in the first place.

    The problem you have with izap_videos might be rather a caching issue than a principle problem with your Elgg version. It seems the language tags are shown instead of the correct text. The missing server analysis tab might also indicate this. Is izap_videos 3.7b the first version you ever installed or did you upgrade from a former version?

    It might help to disable simple cache and filepath cache and also to run /mod/izap_videos/upgrade.php (regardless if you have upgraded to 3.7b or if it's a fresh install). Maybe it's also a conflict with another plugin/theme. But I would suggest to first check if it's a caching issue. Disabling caching should show you if that's the case. If it works correctly then you can enable caching again.

  • Thanks for your help! I indeed upgraded izap_videos adn never did clear the caches and run the update script, so I will do that now and see if it fixes things.

  • OK I turned off simple cache and filepath cache, deleted the views_simplecache directory in data, and turned caches back on again. No change in the tabs issues.

    I get this error when I try to run /mod/izap_videos/upgrade.php

     

    Fatal error: Call to undefined function datalist_get() in /home/russoj/public_html/edu/mod/izap_videos/upgrade.php on line 32

    Any other ideas? Should I try 1.6.3?

  • Line 32 is

    if((real)datalist_get('izap_videos_version') < 3.55){

    ...

    I'm not sure if the "(real)" is causing the problem. This might be a php issue as datalist_get seems to have existed in Elgg 1.6 already.

    What version of izap_videos had you installed before the upgrade to 3.7b? You could remove this if clause completely, i.e. in case of Elgg 1.6.X the following two commands would remain:

     $cleared = clear_all_plugin_settings('izap_videos');

    upgrade_izap_videos_to($new_version);

    What you should also do is to remove the "izap_queue_db" in Elgg's data directory in case it already exists before running upgrade.php. You might start again with first disabling izap_videos, disabling caching, removing the izap_queue_db folder. Then enabling izap_videos, running the upgrade.php script, then adjusting the settings on izap_videos's admin tab, i.e. enabling On_Server videos etc.

    The additional tabs in the admin area of izap_videos should only appear after enabling On_server videos. If it looks right enable caching again.

  • Thanks so much for walking me through this! I'm still not having any luck with the upgrade script. Now it's saying: Call to undefined function get_version()

    I also don't seem to be able to save the Video settings, now. I've checked the boxes for OFFSERVER ONSERVER and EMBED but it doesn't take. So, NO tabs on the new video page.

    I'm thinking I should do the 1.6.3 update because I might need the clean install of Elgg. The problems may be beyond izap_videos? That's going to take me a day or two, though.

  • A pity it doesn't work out.

    Maybe ONSERVER support can't be enabled due to the PDO extension missing on your server. I don't know if this is checked by izap_videos when you try to enable ONSERVER video support. Are you sure that you have PDO drivers installed on your server? But OFFSERVER and EMBED should work nonetheless independently of this. Have you tried to enable only one at a time? The additional tabs most likely only show up with ONSERVER support enabled.

    I'm not sure if upgrading to Elgg 1.6.3 will solve your issue with the undefined funtions. As far as I know 1.6.2 and 1.6.3 were mainly security issues that didn't implemented new features. Take your time with the upgrade though. How about upgrading to Elgg 1.7.3 directly? Of course, you would have to check for all your plugins being compatible with Elgg 1.7+ first and this should be done carefully before the upgrade.

  • @iionly:
        System will not allow to enable ONSERVER feature if PDO libraries not installed.
    @julie levin russo:

    iionly is right, upgrade to elgg 1.6.3 might not causing this problem. This seems to me conflict with other plugin. And one more thing, you no need to run upgrade.php explicitly. It will be automatically upgraded if required.
    Thanks

     

  • Success! I'm not sure what was screwy and interfering with the plugin, but after updating everything to 1.6.3 the tabs are working.

    Now that I can see the server diagnostics, I do need to sort some things out with my webhost before I can support onserver videos. Still excited about the plugin, though.

    Thanks for your help!