Token Mismatch Error

everytime one of my users try to login on the first try they get the below error

We encountered an error (token mismatch). This probably means that the page you were using expired. Please try again

but when they try logging in a second time theres no issue. I have also experienced the issue.

please help !!

  • Thank you so much @Cash for your help.

    By the way my table $prefix_site_entity says that my url is Any ideas? :)

  • In my experience, as long as you are consistent with your url you should be fine. This means you should be hitting the same url as what's in your database.

    1. What browser are you using? (Does IE7 give you the token mismatch error also?)

    2. If you get the token mismatch error, does it go away after the second login attempt?

    3. Do you end up with two cookies for your site?

  • I use FireFox 3 but I'm aquainted with the cookie thing and I switched to the IE7 and Opera 9 as well and all to no avail. I downloaded the sql-base to my local installation and tried to repeat the bug locally but it just won't happen again :( It's ceazed to exist since I cleared the $prefix_users_session at my server.

    The bug was born due to the following actions

    1. I logged in as an admin

    2. I logged out

    3. I registered as a new user but didn't confirm the validation via email

    4. I tried to log in as an admin and failed -as it turned out the gate_keeper() function just won't let me.

  • Very odd. I've done those sequence of steps before and did not experience any problems.

  • Hello,

    I'm having the same problem as Boris but with the diference that after following all the steps he posted, the problem get solved but just for the first login and then it comes back.

    This is really anoying and after writing my own functions to replace the problematic ones I found new and more complex problems. So now I'm thinking on removing elgg and moving to another solution as dolphin, because elgg is extremely unstable.

    In addition to this, some actions are giving me blank pages, in another new instalation I made. :(

    Any idea that could help me?

  • I have investigated dolphin and even have a lifetime add free licences however after investigation we came to the conclusion dolphin cannot support the user base that we have. Anything more than 1000 members and anything more than 20 users online at a time and your database will stall

    if you would like to investigate this yourself please read this thread on the dolphin site before getting involved.

    Dolphin is a nice package however if you want to have a serious site  with serious loads I don't think it can handle it

  • I don't know if I'm repeating info but on dreamhost I had the option of always removing the "www" from my domain when someone went there.  this fixed this problem for me.

  • In the admin to your site, click "site admin" then look at the "The site URL, followed by a trailing slash:"

    - either add or subtract the "www." Also make sure it is the complete url including the http:

    I had that problem and when I changed it, I added the "www.", I stop getting the "token mismatch" errors.

  • I am having url of the form

    And i ma still getting this same error.Please suggest some solution.


  • Has anyone who gets this token mismatch error ever thought of googling for "token mismatch error" ?

    Mi a amigo Cash Costello en NYC has *already posted the solution mucho months ago ;-)