file size null

hi, I need help;

when I upload a file, the file successfully uploaded but the size of the file is null, i have elgg1.7

I changed in /opt/lampp/etc/php.ini and .htaccess this parameters:

post_max_size= 800M  upload_max_filesize=200M   memory_limit=1G

thank's in advance

  • Have you tried with a small file first?

  • hi Cach, thank's;  yes it works with the small file, the problem appear when the size >5M.

  • @vpn_31:

    Check the settings in .htaccess.

  • hi iionly;

    In .htaccess i have this parameters post_max_size= 800M  upload_max_filesize=200M   memory_limit=1G, is there another parameter?

  • The Tidypics photo plugin has extensive documentation on this. Otherwise, a google search will turn up what you need to upload large files using PHP.

  • max_execution_time and max_input_time also need to be large enough. Tidypics and also Izap_videos have server analysis pages that will show the values of all relevant php variables.

    If you still can't upload files >5M it might be due to your server configuration and the php values in .htaccess are not used at all. Maybe you will have to set the values of the variables in php.ini. You could also ask your hoster's support where to define the settings for the server config used.