IZAP videos - error code: not uploaded + no thumbnails for youtube vids - v.3.7b

I have been testing 3.7b version of Izap Videos (Elgg version 1.7.1) and found that even though all the server tests are green I am unable to upload videos to the server.

When I click 'Save' on the video upload page, the progress bar completes and a red warning message is presented which reads similar to 'error code: not uploaded'.

I don't have any more information that that presently. Is there something you know of that I might change to correct this? (the file upload max sizes are big enough for the video I am uploading). n.b. I just ran the test again and this time there was no red error message but the video still did not appear in the video list.

I'm also seeing that image thumbnails are not being autogenerated for videos that are embedded from youtube; instead I see an image with 3 left pointing arrows.

Any tips on this would also be greatly appreciated.



  • What format has the video you tried to upload? Release 3.7b had a bug that stopped FLV uploads to work, but this is already fixed in the latest svn release (r88).

    Just tested embedding of a youtube video ("Add URL") and the thumbnail showed. Maybe it fails only with some youtube videos (problem not of izap_videos but of youtube?).

  • hi lionly,

    I didn't know there were free releases other than the ones that are linked for direct download from the plugin community.. Where do I go to get the latest free version if it isn't 3.7b?

    I think the video i uploaded was an flv, yes.. I'll have a go with a different format.

    The issue with the missing thumbnail images has been the same on multiple youtube video embeds and also a google video embed.. so I don't think its a youtube glitch...

    I'll let you know if I find any more info.


  • There's a site at http://code.google.com/p/izapvideos/ where you can checkout SVN versions of izap_videos. But these are development versions, so they might not fully work. If you intend to use these latest versions, I would suggest to test it on a test installation first. I also use diff to see what has changed.

    The thumbnail creation don't work with all sites unfortunately. For example Dailymotion videos never have a thumbnail. I think it's because the API of these sites don't offer the possibility of thumbnail creation. Then you get only a placeholder instead of a real preview picture. Also very short videos (<10 s) don't get a thumbnail, because the screenshot is created at a playtime of 10 s. For Youtube videos it works for me though. Do you get any thumbnails at all, for example for uploaded videos? If not it might be caused by non-working settings for the thumbnail creation.

  • ah thanks, I'll take a look at the svn repository in a bit. :)

    I uploaded a video and the thumbnail was correctly created, so its only an issue with embedded vids for me right now.

  • I have installed the latest release - 3.71b and the thumbnails are still not showing.

    could this possibly be because I am running the plugin on my local pc rather than a webserver?!

  • Are you talking about thumbnails captured from youtube or on server thumbnails. If they are concerned to offserver videos, than it could be reason of CURL. And if it is on server issue, than i could have 1) permission issue. 2) your ffmpeg is not taking screen shot of the mentioned frame.

    That's what i could think for the time being.


  • when I embed a youtube video the youtube thumbnail is not imported/created in the elgg system, so I see a 'placeholder' image instead of the thumbnails. the 'on server' thumbnails seem to be working correctly.

    I have also discovered that if i manually upload a thumbnail image for an embedded youtube video (via the optional upload field) - the image appears correctly on the main video listing page but not on other pages such as the group index page (where the video was uploaded to a group) - here there is no 'placeholder' image, just a 'missing link' style placeholder (browser default) and thus there is no image at all.

    I do have CURL installed.. I don't know anything about it though.. Is there anything I can tweak?

    thanks again

  • oh, additionally.. It would be a great help if this plugin supported the Elgg category system. :)