Upgraded to 1.7.1 now won't recognize me as an admin

Hi there,

I upgraded to Elgg. 1.7.1 from 1.6 by following instructions in this file:


I disabled all the plugins (the 'core' ones?? which one is that?)

Now it doesn't recognize admin at all, i have to log in from some place else, and that person had admin permissions, but not after the upgrade.

i need to get back in to enable plugins, but without admin permissions, i can't seem to do it.

anyone know where to look?

  • This is what I have done:

    Followed these instructions:

    Deactivated plugins
    Overwrote files
    Modified .htaccess file
    Modified engine/settings.php
    Ran upgrade.php

    I've also tried reinstalling elgg from scratch (in a new folder) and
    giving it the original database information, and it just ends up
    redirecting to the original installation, and I still can't log in as
    an admin.

    It seems like there is just one thing I'm missing here, it might be a
    simple fix that I'm not seeing. Any suggestions would be greatly


  • The upgrade script sets the admin permissions. If you can't get it to work, you could open up the users entity table and edit the admin column for your user.

  • Hi there,

    I ran the upgrade.php several times. I went into the users_entity table and there I'm listed on the very top. It doesn't have a column for admins permissions there it just has:

    guid name username password salt email language code banned last_action prev_last_action last_login prev_last_login

    Which one do I set admin permissions?

    I can't even log in with my username and password. I have to log in wiht someone else's username and password, they should have admin permissions, but they dont.

    It's all very frustrating (I've been at this problem for 8 hours straight now).



  • Check the version value in your datalists table. It should read "2010040201". Also check the file /version.php

    Basically, the upgrade scripts have not run and it's possible something went wrong when you copied over the code. It sounds like you are not using 1.7.1 code from what you have described.

  • It is 1.7.1 because i downloaded it today. The zip file said 1.7.1


    Here is the code in the version.php

     * Elgg version number.
     * This file defines the current version of the core Elgg code being used.
     * This is compared against the values stored in the database to determine
     * whether upgrades should be performed.
     * @package Elgg
     * @subpackage Core
     * @link http://elgg.org/

    // YYYYMMDD = Elgg Date
    // XX = Interim incrementer
    $version = 2010040201;

    // Human-friendly version name
    $release = '1.7.1';

  • Oh and there is no version value in the datalists table... let me run a search on that value

  • Ok, so I ran a database search on the entire database for the elgg...and there is no "2010040201" value anywhere.... is there a way to update the database? Or should I try again to upgrade the site from the beginning?

  • I ran the upgrade.php admin again... and this is what is says


    MySQL server has gone away

    QUERY: INSERT into memdatalists set name = 'version', value = '2010040201' ON DUPLICATE KEY UPDATE value='2010040201'

  • Did you see that before?

    Basically, your server is set up to cut off the connection to the database before Elgg finishes the upgrade. This is a common problem on cheap shareding hosting sites.

    What version are you upgrading from?

    Also, what value does version show in the datalists table?

    If you are coming from Elgg 1.6, you could try upgrading to Elgg 1.7 first. That might complete before your timeout issue.

    Whatever you do, make sure you have a backup of your database.

  • Hi there,

    No, I didn't see it before.. because I literally did everything.

    I am upgrading from 1.6.1 and not sure where to find 1.7, and I'm using arvixe hosting, i'll ask if they can extend the timeout issue, if they say they specialize in elgg hosting.

    Luckily I do have a backup of my database.

    The datalists table doesn't have a version that I can make out.. is there someplace I shoudl be looking?