White page after putting correct data directory


I have recently got a VPS which has a KLOXO panel. I wasn't quite familiar with KLOXO. So, took a while to understand a couple of few things that are needed now and then.


OK, so I finally decided to migrate my Elgg 1.6.1 site to this new server. I copied the Elgg installation folder and data directory and edited the required Tables on MySQL and still get a white page when visit the URL.

The Apache mod rewrite is installed there correctly.


Strangely, whenever I put a wrong path to my data directory, the site shows up. Not in a needed manner of course. But, it atleast shows up.


So, this means that there's somethign wrong with my data directory ...?

But. I have copied it from the backup, gave it 775 permission and even tried 777.


Could anyone please tell me what needs to be done to make the site work properly ...!

  • Check the Elgg wiki for debugging blank screens

  • I have read it.

    I think the previous host had somehow replace the .htaccess file. I changed it renaming htaccess_dist. But now getting this screen.

    * @copyright codeBrane 2009 * @link http://codebrane.com/blog/ */ require_once($CONFIG->pluginspath . "blogwatch/lib/blogwatchlib.php"); global $CONFIG; /** * Initialises the plugin */ function blogwatch_init() { global $CONFIG; // Initialise our database tables if (!is_blogwatch_schema_installed()) { init_blogwatch_schema(); } extend_view("object/blog", "blogwatch/blogwatch"); extend_view("forum/viewposts", "blogwatch/blogwatch", 1); extend_view('metatags', 'blogwatch/metatags'); if(isloggedin()) { extend_view('profile/status', 'blogwatch/profile'); } } // Register our event handlers register_elgg_event_handler("init", "system", "blogwatch_init"); register_elgg_event_handler('annotate', 'object', 'blogwatch_new_comment'); register_elgg_event_handler('delete', 'object', 'blogwatch_delete_subscriptions'); // Register our cron handler register_plugin_hook('cron', "fiveminute", "blogwatch_cron"); // Register our actions register_action("blogwatch/form", false, $CONFIG->pluginspath . "blogwatch/actions/form.php"); register_action("blogwatch/subscribers", false, $CONFIG->pluginspath . "blogwatch/actions/subscribers.php"); register_action("blogwatch/subscriptions", false, $CONFIG->pluginspath . "blogwatch/actions/subscriptions.php"); // Register the BlogWatch entity register_entity_type('object', 'blogwatch'); add_subtype('object', 'blogwatch', 'BlogWatch'); ?> * @copyright codeBrane 2009 * @link http://codebrane.com/blog/ */ $english = array( // River "item:object:blogwatch" => "Updated blog post or group discussion topic", // Notification strings "blogwatch:notify:subject" => "notification", "blogwatch:notify:body:header" => "The following post or topic has been updated", "blogwatch:notify:body:footer" => "please note you may have to login before viewing the post or topic.", // Cron output "blogwatch:cron:return:string" => "blogwatch notifications available", // Main blogwatch view "blogwatch:view:blogwatch:subscribe:button" => "Subscribe", "blogwatch:view:blogwatch:unsubscribe:button" => "Unsubscribe", "blogwatch:view:blogwatch:subscribers:button" => "Show subscribers", "blogwatch:view:blogwatch:subscribers:popup:title" => "Subscribers to", // Profile page "blogwatch:view:profile:status:subscriptions:button" => "Show my subscriptions", "blogwatch:view:profile:subscriptions:popup:title" => "My Subscriptions", ); add_translation("en", $english); ?>

    I tried changing the #Rewritebase by putting the path of my elgg install and commenting it out. But, it is just the same.

    Could anyone help me out a bit, please!

  • Shouvik , remove the blogvatchplugin, or try a fresh new Elgg install

    Team Webgalli

  • I have successfully restored the site on my WAMP server. Thank you for your suggestion, Team Webgali.


    But, on my VPS, there seems to be a problem. I have noticed such screens when Elgg fails to establish a proper connection with the data diretory.

    I have set the permission to 775 (again, tried with 777 as well), but not use!


    It's a bit difficult to explain how it looks. Could you please visit the site and take a look at it yourself ... http://ppsz.info

  • Webgalli already told you what you should do. Blow away the install on this site, create a fresh install, get that working, and then migrate your previous site. (And no, it does not look like a permissions issue on your data directory. It is a htaccess issue.)

  • I just did a fresh install and linked it to the existing database. The result is just the same. :(

  • Shouvik, Me and Cash gave you the same solution but we can't understand, why you are not doing that. Like as Cash mentioned, the problem is with your ".htaccess" file. Check whether your ".htaccess" file is empty or not. If its empty rename "htaccess_dist" to ".htaccess"

  • To be more pedantic about this, do the following:

    1. Delete all files where your install is (including .htaccess)
    2. Create a new database on the new server
    3. Copy the Elgg code to the new server
    4. Install Elgg

    Do not try to link it to an existing database or anything else until you have a working Elgg install. Once you have Elgg working, then you can point the install at another database.

  • If he is using lighttpd, the rewrite rules need to be rewritten for that web server or he needs to switch to Apache - but he is claiming it is running Apache.

  • DhrupDeScopp: So, was it you who fixed it?

    A friend of mine told me that the problem could occur with lighttpd. Changing it to Apache would solve it.

    Now most of the things are resolved. There's a problem with login. Whenever I try to login, get the following error notification -

    The requested action (login) was not defined in the system.


    When I try to retrieve my password from the 'lot password' page, I get the following error notification -


    The requested action (user/requestnewpassword) was not defined in the system.


    Could you please help me resolve this ...!