install problem - start script quits


I've verified requirements, etc. and have correct versions of Apache (with modrewrite turned on), MySQL, etc. on Mac OSX Snow Leopard.

Tried to install Elgg:

1. created new database in MySQL for Elgg and it seemed to like it

2. after that, it is going thru' start up script and exiting at

if ((!$installed || !$db_installed)
    && !substr_count($_SERVER["PHP_SELF"], "install.php")
    && !substr_count($_SERVER["PHP_SELF"],"css.php")
    && !substr_count($_SERVER["PHP_SELF"],"action_handler.php")) {
        header("Location: install.php");

3. In addition, am getting three date() warnings (one of which is below):

Warning: date() []: It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'America/Los_Angeles' for 'PDT/-7.0/DST' instead in /Library/WebServer/Documents/elgg-1.7.1/engine/lib/metadata.php on line 123

4. Other than these warnings nothing shows up - blank page...

Any pointers? THanks.

  • 5. Also did the htaccess stuff and it seemed to like it.

  • Can ignore date warnings. It should redirect to the install page. Blank page normally means PHP crashed - the wiki has information on displaying the error message: - and no, you should not see a blank page on a normal install. Most install problems are because of  module rewrite/AllowOverride issues.

  • hi thanks for the reply.

    1. Per this wiki, i turned on display_errors to 1, but did not get any other PHP errors.

    2. Then I checked all the versions and settings again and although I had turned on module_rewrite, I did not have AllowOverride set to All (BTW, did not find this instruction in the regular install docs - only in troubleshooting). Anyway, so I changed http.conf with AllowOverride to All in all 3 places and restarted Apache, but no luck - am getting the same blank page with the date warnings.

    3. I've checked everything else - MySQL is in standard mode, PHP is 5.3 with GD, JSON, XML and multibyte. Not installing any additional plugins - just Elgg as downloaded from

    Any other ideas, plz let me know

  • latest update: i've verified that mod_rewrite and ALlowOverride works correctly using the test given in the Wiki :

    still blank page...

  • goose, if you have a blank page in PHP you should have something relevant in your PHP error log.

    Without more information (like an error log message) it is going to be hard to help.

  • Hi, Good suggestion - I checked the apache log file and found couple of things:

    1. fast cgi was turned on by default - hence, turned it off and restarted.

    2. there is only one other error/warning mesg - it seems related to the date warning i'm getting - see below - "cannot modify header info" - full error log since restart is below.



    [Wed Jun 16 13:42:40 2010] [notice] caught SIGTERM, shutting down
    [Wed Jun 16 13:42:48 2010] [warn] Init: Session Cache is not configured [hint: SSLSessionCache]
    [Wed Jun 16 13:42:49 2010] [notice] Digest: generating secret for digest authentication ...
    [Wed Jun 16 13:42:49 2010] [notice] Digest: done
    [Wed Jun 16 13:42:49 2010] [notice] Apache/2.2.13 (Unix) mod_ssl/2.2.13 OpenSSL/0.9.8k DAV/2 PHP/5.3.0 configured -- resuming normal operations
    [Wed Jun 16 13:43:06 2010] [error] [client ::1] WARNING: 2010-06-16 13:43:06 (PDT): "Cannot modify header information - headers already sent by (outpu\
    t started at /Library/WebServer/Documents/elgg-1.7.1/engine/lib/metadata.php:123)" in file /Library/WebServer/Documents/elgg-1.7.1/eng\
    ine/start.php (line 183)

  • The headers already sent looks like the problem. metadata.php should not be sending any data out. Have you changed it from the original file? You might try copying the original code over.