elgg 1.7.1 php/fastcgi issue

Has anyone found a way to get 1.7.1 to run on a server that is configured properly in every way except that php is installed as a cgi/fastcgi module?

I ask because I can get everything to work right as long as I access the site in firefox. I8 sits trying to load the site forever and chrome returns an error message sayng the site is tryng to redirect the user in a way that will never work.

Evey single technical requirement is configured properly except php is insalled as  cgi/fastcgi instead of as an apache module. Unfortunately the two servers that have this issue I cannot reinstall php as an apache module.

So I thought I would come in and just ask if anyone has found a work around for this issue yet.

Douglas Wolfe

  • Please do not cross post.

    There is some junk in Elgg's htaccess file that needs to be cleaned out. Try removing:

    <IfModule !mod_rewrite.c>
        # ugly ugly hack to detect missing mod_rewrite
        # RedirectMatch must be to an absolute destination, so forces 500 error...
        ErrorDocument 500 "Elgg error: Apache does not have mod_rewrite loaded. Please check your Apache setup."
        RedirectMatch 302 .* index.php

    # php 4, apache 1.x
    <IfModule mod_php4.c>
        ErrorDocument 500 "Elgg error: Elgg does not support PHP 4."
        RedirectMatch 302 .* index.php

    # php 4, apache 2
    <IfModule sapi_apache2.c>
        ErrorDocument 500 "Elgg error: Elgg does not support PHP 4."
        RedirectMatch 302 .* index.php

  • Thanks Cash,

      I will give it a try.

  • Sorry about cross posting, I posted in the one group before I saw the tech support group.


  • Hi Cash,

           I removed the sections you mentioned. Funny on the server where php is installed as cgi/fastcgi api it worked. At least so far, I am still installing mods and testing them.

           However on the server where php is installed as cgi it has not yet worked.

    I am still working on the second server and hope to get it working today as well.

    Thank you again for your help

    Douglas Wolfe

  • You may find this interesting cash. I finally got it to work on both servers and one in a sub directory.


    Basically I did exactly as you sugested on the shared server where php was installed as cgi/fastcgi.

    I tried that on the VPS server where it is runningin a subdirectory and they are running modx on the root directory, it didn't work right off there.

    Adding the RewriteBase did nothelp either. 

    but between

    #RewiteBase  and (commented out in the htaccess file)

    RewriteRule ^services\/api... line

    The vps server has to have this additional line of code:

    RewriteRule ^action\/([A-Za-z0-9\_\-\/]+)$ engine/handlers/action_handler.php?action=$1

    Now when we are done both these installations will have somewhere near 100 mods and plugins added to what is thereby default. at this time I only have about 30 of those added in. Yet everything is working so far. I will let you know if everything works together fine once I get all installed and post a list of mods included if you would like.


    Douglas Wolfe



  • Thanks for reporting back. The line that you added to the .htaccess file is in the default version that comes with Elgg or am I missing something?