elgg 1.7.1 php/fastcgi issue

Has anyone found a way to get 1.7.1 to run on a server that is configured properly in every way except that php is installed as a cgi/fastcgi module?

I ask because I can get everything to work right as long as I access the site in firefox. I8 sits trying to load the site forever and chrome returns an error message sayng the site is tryng to redirect the user in a way that will never work.

Evey single technical requirement is configured properly except php is insalled as  cgi/fastcgi instead of as an apache module. Unfortunately the two servers that have this issue I cannot reinstall php as an apache module.

So I thought I would come in and just ask if anyone has found a work around for this issue yet.

Douglas Wolfe
wolfepk1@gmail.com
www.wolfeinteractivedesigns.com