Installing Elgg on Ubuntu 10.04

I'm trying to install Elgg on a vanilla install of Ubuntu 10.04 (Server 64-bit)...  I'm following this ubuntu guide from the docs page.

I'm having some difficulty with step 6.

6. Edit /etc/apache2/available_sites/default to allow URL rewrites

first of all there doesn't seem to be a preexisting file called /etc/apache2/available_sites/default there is however a similarly named file called vim /etc/apache2/sites-available/default.  When I edit this file to allow URL rewrites it doesn't seem immediately obvious to me what I have to add or change to make this happen.

Does anyone have any suggestions?

  • My current /etc/apache2/sites-available/default file looks like this...

    <VirtualHost *:80>

            ServerAdmin webmaster@localhost


            DocumentRoot /var/www

            <Directory />

                    Options FollowSymLinks

                    AllowOverride None


            <Directory /var/www/>

                    Options Indexes FollowSymLinks MultiViews

                    AllowOverride None

                    Order allow,deny

                    allow from all



            ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/

            <Directory "/usr/lib/cgi-bin">

                    AllowOverride None

                    Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch

                    Order allow,deny

                    Allow from all



            ErrorLog /var/log/apache2/error.log


            # Possible values include: debug, info, notice, warn, error, crit,

            # alert, emerg.

            LogLevel warn


            CustomLog /var/log/apache2/access.log combined


        Alias /doc/ "/usr/share/doc/"

        <Directory "/usr/share/doc/">

            Options Indexes MultiViews FollowSymLinks

            AllowOverride None

            Order deny,allow

            Deny from all

            Allow from ::1/128




    What do I need to add or change to allow URL rewrites?

  • my file looks exactly like yours.  I didn't even bother with this step and my elgg install works fine.  have you tried uploading install zip file, extracting it, and running install.php?

    I just did the instructions from HERE

    EDIT: I'm also on ubuntu 10.04 and that's where my default file is located... not sure if that makes you feel better

  • Thanks!  I didn't want to miss a step that caused future problems... But if it seems to be working for you I'll continue on! 



  • I've corrected the instructions.

  • Really how complicated is the people. Anyway UBuntu 10.0.4 install Php 5.3 and Php 5.3 not work fine with many scripts and plugins

    I go to post after the correct instalation for Ubuntu 10.04

  • The first we need to make before install Nothing is downgrade PHP 5.3 to PHP 5.2

    There many system in Google but the better is this simple script I make a few corrections And work fine.

    1. You need en root make : sudo gedit
    2. Copy and paste the code I post down
    3. Save
    4. make: chmod +x
    5. make: ./
    6. The script start working and ask few times keep old configurations. You always say NO
    7. If you make all correct Now you have php version 5.2 working


    # remove all php packge
    sudo aptitude purge `dpkg -l | grep php| awk '{print $2}' |tr "\n" " "`
    # use karmiс for php pakage
    # pin-params:  a (archive), c (components), v (version), o (origin) and l (label).
    echo -e "Package: php5\nPin: release a=karmic\nPin-Priority: 991\n"  | sudo tee /etc/apt/preferences.d/php > /dev/null
    apt-cache search php5-|grep php5-|awk '{print "Package:", $1,"\nPin: release a=karmic\nPin-Priority: 991\n"}'|sudo tee -a /etc/apt/preferences.d/php > /dev/null
    apt-cache search -n libapache2-mod-php5 |awk '{print "Package:", $1,"\nPin: release a=karmic\nPin-Priority: 991\n"}'| sudo tee -a /etc/apt/preferences.d/php > /dev/null
    echo -e "Package: php-pear\nPin: release a=karmic\nPin-Priority: 991\n"  | sudo tee -a /etc/apt/preferences.d/php > /dev/null
    # add karmic to source list
    grep 'main restricted' /etc/apt/sources.list|grep -v "#"| sed s/lucid/karmic/g | sudo tee /etc/apt/sources.list.d/karmic.list > /dev/null
    # update package database (use apt-get if aptitude crash)
    sudo apt-get update
    # install php
    sudo aptitude install -t karmic php5-cli php5-cgi
    # or (and) sudo apt-get install -t karmic  libapache2-mod-php5
    sudo aptitude hold `dpkg -l | grep php5| awk '{print $2}' |tr "\n" " "`
    sudo apt-get install libapache2-mod-php5


    a2enmod ssl 
    a2enmod rewrite
    a2enmod include


    IN you can get the control panel

    a2enmod include


  • Thanks for the C&P script, but it should be said that if you have any modifications to your PHP config it will wipe them without asking.  Also, why are you pinning the PHP versions?

    The commands listed at are now accurate and should work for everyone on Ubuntu.

  • HI

    1.- The script delete all your php 5.3 files and Install php 5.2

    This means in the moment of reinstall the system ask for keep your php old configurations or write a new

    I pinning the PHP version Because if not The next time you install any Php module or possible the next time you upgrade your system. Ubuntu go to change again your php 5.2 for 5.3

    The system to stop that is pinning the php version :)

    Again Elgg work in PHP 5.3 but many plugin only work correct in 5.2.

    Also Joomla, a2billing ... not work correct in Php 5.3. The recomendation of the Ubuntu community is downgrade to 5.2




  • Thanks for the explanation Jacob.  I didn't realize php 5.3 was that unloved in the Ubuntu community ;)

    I develop Elgg on PHP 5.3.1.  There have been a few reported cases of problems with 5.3, but I haven't been able to duplicate these problems.  Just out of curiosity, which plugins don't work correctly in 5.3?

  • UHm By example the plugins of video and others I never make work in php 5.3

    And is not a question of unloved is a question of many other scripts also  not from elgg not work fine