Can't de/activate Plugins


I'm not able to de/activate plugins anymore. when i click on the button "acitavte"/"deactivate" it shows me just a plank white page. 

can anyone help ?



  • they upgraded to 128 MB ... no changes ... how can i find the script-issue ?


    btw disabling plugins with brett's method fails ... :-(


    If anyone is willing to help i would give you the ftp and elgg account to have a look at it through PM.

  • "Your host does not want to give you more memory" ? I had 512MB on my ex-$8 shared hosting ;-) Now we run 8GB + 2Gb + 2GB mem ;-O .. You need to get a new Host ;-) or you can always come to us when we later do open up as an elgg-host ourselves lolz..

  • @idiotter - Small Elgg sites will run with 128 MB ram so you don't need to switch hosting yet...Throwing more ram at the problem is just a bandaid.  Have you disabled all 3rd party plugins?

    I was incorrect about disabling the plugins one at a time with a disabled file.  Here are the instructions for disabling all at once:

    What you need to do to track this bug is disabled all 3rd party plugins and enable them one at a time until the problem comes back.

  • @All - I disabled Idiotter's PlugIns last night by logging into his account ;-)

  • I'm having the same problem, and using Bretts method of adding the disabled file does disable all plugins, but I can't access the tools admin, it just comes back to the fatal error screen, other than that the site is back up in the basic form.

    How do I now get access to the plgins to enable them one by one?


  • Is anyone looking @ this anymore?  I hope so.

    I running 1.7... I installed a tinymce plugin in the mods section... and I get the white screen of death.  I tried to replace the plugin with the original plug in.

    But still received the white screen of death.


    I used the method in this thread creating a "disabled" empty file.  I can now login to my Dashboard... but when I go to Tool Administration I am still getting a fatal error Fatal error: Allowed memory size of 67108864 bytes exhausted (tried to allocate 79 bytes) in /var/www/elgg/engine/lib/metadata.php on line 40


    Anyone have any helpful suggestions?



  • Did you read all of the comments from the top ?

    The answer to your problem is already up there ;-)

  • I'll try and not return a condescending remark with the same.  Yes I have.  The site worked 100% prior to this.


    Honestly, I've never seen such a fragile piece of software.

  • @JRA3, I have had this type of problem before.  I had to deactivate all the plugins... but it was not that simple either.  I renamed the Mod folder I was using and copied a bog standard Mod folder and contents to my installation and then added and subtracted my desired plugins until I found the problem... diferant to your no doubt, but mine was a missing ; or ) from a language file...  It is surprising how somthing so small can cause such a major headache!

  • @Mark,


    Thanks.  I have tried that strategy.  I renamed the MOD folder I've had a problem with.  Uploaded a new standard install MOD folder.  I do that... the site loads, I can login... but there are no plugins when I go to Administer Tools; there is nothing there to enable or disable.  Any idea what that might be happening?