Can't de/activate Plugins


I'm not able to de/activate plugins anymore. when i click on the button "acitavte"/"deactivate" it shows me just a plank white page. 

can anyone help ?



  • Hello idiotter,

    I think you can do it by going to your mod directory and create an empty file named disabled

    Thats it. You are done, not you can remove or rename the mod/plug that causing the problem. 

    Once you are done, remove/rename the disabled file from the mod folder.


  • What version of Elgg are you using?  Can you turn on display_errors in .htaccess?

  • I've been struggling with a similar problem. I have a plugin that we wrote. It works fine on my workstation but in the live site when you log in you land on a blank page (/action/logout) and I have to manually past the URL of the plugins (pg/admin/plugins/) tool administration. When I disable my plugin it works fine

    so /pg/admin is blank. /pg/admin/plugins works. Why would my plugin affect login? Help!

    FYI - I deployed from my workstation - this is the same code base that I am running 100% fine on my workstation. At this point I am rather confused. Would appreciate any assistance to get this moving in a direction I can debug.


  • @democracy i don't know which plugin makes the trouble ... 

    @brett i'm using 1.7.1 my host says display_errors is always on and i turned it on no 

  • when i try to activate pedropez like plugin i get this: <br />

    <b>Fatal error</b>: Allowed memory size of 67108864 bytes exhausted (tried to allocate 79 bytes) in <b>/home/httpd/vhosts/</b&gt; on line <b>271</b><br />
    when i try it with the quotes plugin this
    <br /> <b>Fatal error</b>: Allowed memory size of 67108864 bytes exhausted (tried to allocate 64 bytes) in <b>/home/httpd/vhosts/</b&gt; on line <b>271</b><br />
    and fbconnect this: <br /> <b>Fatal error</b>: Allowed memory size of 67108864 bytes exhausted (tried to allocate 24 bytes) in <b>/home/httpd/vhosts/</b&gt; on line <b>271</b><br />

  • OK, - just checked my error log:

    [19-May-2010 10:49:53] WARNING: 2010-05-19 10:49:53 (CDT): "Invalid argument supplied for foreach()" in file /home/buyfulco/public_html/engine/lib/plugins.php (line 723)

    This code looks like:

    foreach ($ENABLED_PLUGINS_CACHE as $e) {
      if ($e == $plugin) {
       return true;


    is the global $ENABLED_PLUGINS_CACHE busted? How can I tell?


  • @GEON

    goto FTP and delete the bad PlugIn Folder ;-)

  • Thanks for responding.

    The plugin I am trying to diagnose is the one we wrote. It works on my workstation but not on the live shared hosting at the ISP. Trying to figure out what environmental factor is causing the issues. When you login to the site you get a blank page, when i disable all the plugins site works. When I enable my plugin login breaks. My plugin has pages/css but nothing to do with login... and there is the fact that it works on my local system...


  • @Geoff.. PM me your email, send me a zipfile of yr PlugIn, tell me yr Elgg vers.. I might spend a little debugging time on my XAMPP + server.. no promises, but you might get lucky;;;;-O

  • OK i'll zippit up to ya...