Duplication failed

Hi, I'm trying to duplicate my website on a new server. For that i've moved the website into a test server (every thning in working perfectly on it) , but when I move it to the production server. I've got many issues. First when I delete views_simplecache ,view_paths. It doesn't regenerate when i run upgrade.php. And when i change the URL using UPDATE `elggsites_entity` SET `url` = "http://test.myelgg.org/"; I still see the old URL in some places on the source using firebug (with firefox), notice that i cheked that the value has changed in the database, but still the URL is still being called.

What can I do? Thanks for you help.

P.S: I'm following the same procedure on both servers, i checked URL etc...

  • At some point, I'll update the the duplicate wiki page with my own version (which I think is better). I use sed to process the dump file rather than sql queries to update. The advantage is that it ensures that all the previous URLs get updated.

    It is basically:

    • mysqldump
    • sed to replace old url with new url
    • sed to replace old data directory with new data directory
    • sed to replace old code path to new code path


  • Do you check mod_rewite enabled?

    I have a similar problem, by the time upgrade.php ended i see a blank page, nothing happened.

    I enabled mod_rewrite en my server, specify in my work folder

    <Directory "/var/www/html/elgg">
        Options Indexes FollowSymLinks
        AllowOverride All
        Order allow,deny
        Allow from all
    #service httpd restart   // Restart

  • Yes i did, mod_rewrite is enabled, i used sed to replace the data and now the old URL does'nt show up anymore.

    Now i have got an other issue my main page does'nt diplay the same widgets as in my initial Website. In the old website, the first page contained Newest members, latest files and latest bookmarks, now it displays latest activities. and i could'nt log on. I checked i copied all the folders...etc. What do you think can cause this? Thank you

  • I think that  the issue comes from the cache, when i run upgrade.php i have the following error and the views_path and view_simplecache don't regenerate.


    Table 'elggdatalists' is read only QUERY: INSERT into elggdatalists set name = 'version', value = '2009072201' ON DUPLICATE KEY UPDATE value='2009072201'


    Any ideas?

  • -rw-rw---- 1 mysql mysql   8592 Apr 18 14:45 elgg_datalists.frm
    -rw-rw---- 1 mysql mysql    508 May 19 19:20 elgg_datalists.MYD
    -rw-rw---- 1 mysql mysql   2048 May 19 19:20 elgg_datalists.MYI

  • Thank you, i don't have that error anymore, but still can't make my website work. When i delete the views_path and view_simplecache i lose the styling and i can see using firebug that it could'nt find the CSS, and i see different widgets that the initial widgets diplayed on my okd website.

    Échec du chargement de la source pour: http://www.mywebsite.com/elgg/_css/css.css?lastcache=1274717212&viewtype=default

    is it due to the cache, it's always trying to reach the lastcache=1274717212 and it couldn't found it.How can i initialize the cache properly?


    Thank you