Problem with groups

After changing the file upload size in my htaccess file,  when I go to a group I get this message:


You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'and e.site_guid = 1 and e.container_guid = 25 and ( (1 = 1) and e.enabled='ye' at line 1

QUERY: SELECT * from WBnDentities e join WBnDobjects_entity o on e.guid=o.guid where e.type='object' and e.subtype= and e.site_guid = 1 and e.container_guid = 25 and ( (1 = 1) and e.enabled='yes') order by e.time_created desc limit 0, 1

Is this a coincidence or did I mess something up? Can this be corrected through the php files or should I attempt to remove/replace folders/files?

  • Looks like some code was changed - for example: e.enabled='ye'

    Copy the code over again (should be the code in /engine/lib/)

  • Thanks, I copied over a new group php file and over wrote the existing one but that didn't work. I tried creating a test group and it came back with the same problem. I may be hosed, I am not familiar enough to go into the sql database and find the isuue and correct it. I also cannot get rid of the groups. I understand that this is a known problem and hopefully it will be addressed in the next update. On the other hane, except for this group problem, this is a great platform and I and my users are happy with it so far. We went this route after Ning announced that it is killing off the free sites which is where we were.

  • I said copy the code in /engine/lib

  • I understood that. My question is, copy the code to/from where? I copied a fresh copy of group.php into the /engine/lib folder. Should I replace all the files in that folder? SOrry for my apparent ignorance on this.

  • I suppose Cash means overwrite the contents of your install's /engine/lib with a fresh downloaded copy.

  • Thanks for that. I copied over the entire directory into /engine/lib, but no joy.

  • There is no way to get: e.enabled='ye' with the correct code in /engine/lib. The enabled value is either yes or no, not ye.

  • OK, I downloaded a fresh copy of Elgg and overwrote all the files in /engine/lib/. This time it worked :-) I was sure I replaced all the files last time but apparently I was mistaken. Thank you for your patience and help.

  • Everything was working fine, then I uploaded a file to a group, and I am back to the same problem, however, re-copyine the /engine/lib  files didn't work this time

  • Uploading a file to a group does not edit files in /engine/lib. You have some other issue. Someone is editing your core Elgg files.