Plugin not appearing in Tool Administration

I've copied tidypics into the elgg/mod folder and set the same file/folder owner & permissions as all other plugins, but tidypics does not appear in Tool Administration.  Any thoughts or ideas for how I can begin troubleshooting?  Thank you!

Elgg 1.7.1
tidypics 1.6.8

  • It should be at the bottom of the list. The only reason I can think of for it not being there is a permissions issue. Did you try opening up the permissions (777) just to see if it appears. If it does, then you can focus on figuring out what the correct permissions are for your server.

  • Thank you for your quick reply, Cash.  Yes, I tried 777 and it didn't work.  I checked the Elgg log and don't see any errors.  I see the info show below.  Is there somewhere else I can look for errors?  Other log files, etc?  Thank you.



    GUID:1: pluginorder a:33:{i:10;s:6:"search";i:20;s:7:"members";i:30;s:7:"friends";i:40;s:6:"groups";

  • Those are plugins that are enabled so it is okay if Tidypics does not appear there yet.

    If you put another plugin in mod does it show up?

  • Hmmm, good suggestion.  I just tried installing the "Elgg Mobile" plugin and it too does not appear in the list.

  • Are you sure you are putting them in the correct directory? Try deleting a plugin from the directory to see if that plugin disappears from the list.

  • Yes, I just moved "captcha" out of the /var/www/html/elgg/mod folder and it disappeared from the Tool Administration list.

  • I can move any of them out and they disappear.  I can move them back and they reappear in the Tool Administration list.  I just tried with several.

  • BTW, I'm using CentOS.  I transfer the plugin zip file to the server and use "unzip" to extract the files/folders.  Could "unzip" be doing something to the files?  Everything looks fine after the extraction and I can open/view the files.  I'll try unziping on my PC and SFTPing them to the server...

    ... nope that didn't make a difference.

  • This has been resolved.  When I unzipped the plugin using the "unzip" program, the folder created by unzip had some kind of incorrect hidden extended attributes.  I manually created a "tidypics" folder in the mod folder and the copied (cp) the files from the folder that "unzip" created into the new folder that I created and tidypics has appeared in Tool Administration.  Thank you again for your help.