elgg with eclipse and wamp development, breakpoints don't work

Hello from germany,

i made a test-system with elgg 1.7.1, WAMP 2.0 und eclipse for developers Build: 201000218-1602

PDT and run on localhost workvery works

but eclipse don't stop on breakpoints

i put following in the php.ini (and copy the file in the folder)

; php.ini Options  ;


also i try


what must i do, that eclipse stops at breakpoint ?

tx and nice weekend





  • Any help on this pls? Even I tried the same and it is not working for me.


  • You have to also set up Eclipse to use xdebug.  By default it's configured to use Zend Debugger.  There are many resource on Google about setting up a debug environment with Eclipse and PHP + xdebug.  For the record, I use Eclipse and PHP + xdebug on Mac and Linux as my development platform. ;)

  • Hi,

    I am using Eclipse PDT all in one version, WAMP 2.0 which contains PHP 5.3 and XDebug 5.3 VC6 .

    I had followed the following tutorial as in the below link:


    I have checked the phpinfo. It is working fine as xDebud details are present. However when working with Eclipse the debugger is not working. When I right click the index.php file and select debug the progress tab shows Launching Index 57% waiting.....and web browser displays "Page not found".

    I know this might not be the rght forum to ask, but I am willing to debug Elgg code. So if anybody can help it will be really helpfully. Strugling from past 2 days :(

  • Hi,
    I ran into similar problem although I'm using Aptana and Zend debugger.  Debug session is able to stop at break-points I put in the root index.php but once i resume execute, the debug session just terminated without stopping at any breakpoints I put in other PHP code.  
    I'd makre sure "Debug All Pages" is checked in the debug configuration. What else do I need to configure? I heard it's something to do with Path Mapping but I have no clue how to setup it up properly.   Any help will be greatly appreciated.


  • Hi


    I know it has been a while since you all posted - but I found a solution. Check this website out:




    Got things working for me (with Zend debugger even) like this person ^.


    BTW - I am using Elgg on a LAMP server (Ubuntu 10.04).