URGENT: You do not have permission to view this item.


I have elgg 1.7. It was fine until I logged in last time. But from now, if anyone, (admin, other test user) tries to log in (with different computers) it says, "You do not have permission to view this item." and showing profile icon of a user who became user weeks ago! So, my site is completely unusable at this moment!!!!!

Please let me know what can I do?

Thanks for prompt reply!

  • Hello, 

    I disabled all the mods, then tried to search for the "a user" that was showing..then tried to search different user, got output as below,  (ff and chrome)

    The page isn't redirecting properly

    Firefox has detected that the server is redirecting the request for this address in a way that will never complete.


    *   This problem can sometimes be caused by disabling or refusing to accept




    This webpage has a redirect loop.


    The webpage at http://"MySite.com"/live/pg/search/?search_type=entities&q=testuser1&entity_type=user has resulted in too many redirects. Clearing your cookies for this site or allowing third-party cookies may fix the problem. If not, it is possibly a server configuration issue and not a problem with your computer.


    Here are some suggestions:

    Reload this web page later.

    Learn more about this problem.

      More information on this error

    Below is the original error message


    Error 310 (net::ERR_TOO_MANY_REDIRECTS): There were too many redirects.

  • " [...]showing profile icon of a user who became user weeks ago!"

    Have you tried to delete that user?

  • Dear 4dplane,

    Thank you very much for your reply. I have tried and finally deleted. It also solved the issue too. But, I am curious to know the problem and its real solution. I wonder, elgg should not be this much fragile, so where is my problem? What configuration should I try? 

    Moreover, it was not that simple to delete that user, coz, elgg 1.7 has some issues so that you can not browse users page by page! 

    I am a bit worried about the problem, since I dont know what really caused it?


  • Hi democracy,

    Glad to hear it worked!! From my experience, a problem like that comes from a plugin that allows a user to input a piece of data i.e. text, photo, video etc ... That new data will insert fine and no errors will be reported, but when the user goes to a differnt view (page) / the new data corrupts the page so it cannot be displayed.

    All I can say is “watch your plug-ins”. It was something the user was allowed to add that caused the problem. A slow but effective way is to go through all plug-ins and all their GUI functions and make sure the whole site works.

  • First of all, as soon after I saw this problem, I have deleted the user! (It took time)  then i did the test, like put empty file called "disabled" and that disabled all the plugin. then manually disabled all. after that I enabled one after another. It seemed that bottom_bar or riverdashboard might caused the problem. Coz when enabled any of this, it went to the earlier wrong/not working state. 

    Haauf...then I deleted my valuable user :( coz I had no better intelligence. 

    I am still trying to learn what should be done to prevent this or some other such probs in future?