A very noobish problem

Hi there,

This is probably a VERY obvious answer to everyone out there, but here's my issue:

I've got Elgg set up on my LAMP stack just fine, and I've just started to tinker with the CSS a little. So, to confirm that Win32 browsers are displaying everything ok, I jump on another laptop on my local network and navigate to my IP. The login page loads, but WITHOUT any formatting. Just plain text and submit buttons. Not only that, but the links on the page all point at Local Host, NOT my little servers IP.

So what seems to be happening is that the pages are all point to Localhost itself as an absolute path. Do I need to manually go through all the scripts and change them to my local IP/URL??? Or am I missing something completely obvious? I've only been playing with PHP for a couple weeks, still not too sure about alot of stuff....

Thanks in advance.....

  • Lovegin John


    Please ensure that the URL that you type from your Laptop is the same that you gave in during the installation process. Please update it from your PC (administration=>site administration) and try again from your laptop.


    It may help...

  • Elgg uses the server settings you gave it when installing to build paths.  If you installed Elgg with the address "http://localhost/" then it will output links for that site.  Lovegin's advice should work fine, but if not, since you are just testing right now you could always do a fresh install and use your IP address instead of localhost.