Regular user, no admin access

I've been trying to solve this for weeks.

So I install 1.7 and vanillaforum. Create a new database for vanilla and install it. It went smooth.

After that I activate the vanilla integration plugin. Also smooth. But when I tried to open the vanillaforum from the tool menu, I only saw a regular user view. I cant access the setting, or admin area of vanillaforum.

It seems that vanilla doesnt read me as an admin. I put the admin user name as instructed. Also check the database, the role ID already set to "administrator" which is roleid=4. Same admin user name. I did nothing on the code.

When I tried to install it on localhost it works great. So I was curious it was a server error. But I cant figure out what makes the error.

Any idea what might be the error ?        PHP curl is enabled.

  • I have the same problem. I have vanilla installed and I am using it. I installed a new theme but do not see any of the admin tabs like styles and themes so i can't install the new theme.

  • You should have created an admin user when you installed Vanilla. This plugin does nothing to change that.

    If you are having trouble, then I suggest that you try again from the beginning and re-install Vanilla.

  • Thx Kevin, I will reinstall. Also where is the php curl extension and how do I make sure I have it/ it is enabled?

  • OK it works... I think it got messed up because I used a different username for my vanilla admin account than I did for my Elgg admin account (I think they need to be the same.) If you want to duplicate this and put it in your notes it would be helpful.

  • hi azmi, i dont know maybe you had , but in case if you hadn't , i got the problem too,and i just realized that the plugin cant read the url,

    at first elgg installation i did changed "The site URL" in site administration with http://mycomputername/elgg 

    i found the vanilla url changed into localhost/elgg/mod/.....

    then i try to change "The site URL" again in site administration with 



    and just like that, the problem solved for me :)

  • *maybe you had solved the problem

  • I can't create my own settings, it always says that "

    "Some problems were encountered
    There was a problem authenticating your post information."
  • @elHayaze, @Joe G  i think you misunderstood the admin settings when you filling up the form located in the installation that's why you can't view the forum as an admin. you must put your admin username and password the same as your admin account in your elgg website

  • I have issues that whenever i try to set my own setting in an admin area it always says that

    "Some problems were encountered
    There was a problem authenticating your post information."
    Do i have to purchase the premuim account of vanilla ? Anyone experiencing this.?