File dowloads not working in IE

I maintain a site for work that uses ELGG as a collaborative site.  Uploading files is working fine, but they cannot be downloaded with Internet Explorer (I am currently using 8).  FireFox and Chrome download the file just fine.  I have tried various files and tried reuploading files also.

Any ideas on why this may not be working?  Some other details is that this is on an internal network and we are using https.

  • We have the same issue. Just use the 'Save File' option when downloading and open from saved location.

    There may be a different solution / fix out there, but this works for us.

  • I assume the browser doesn't prompt you to download and just displays the binary data?  This is usually a problem with headers, but it looks like the file mod in 1.7 is sending out the correct ones.  As far as I know, IE only needs the Content-Disposition header to force a download...this may have changed.  What type of file is it?

  • Thanks for the responses.  The download dialog appears, but stops at "Getting File Information..." and then an error comes up a few seconds later saying that it can't retrieve it from the server.

    The file I have been working with most is a pps (power point show) file, but I have tried others too (like doc).  I'll take a look at the files plugin and see what I can find out.

  • Hrm....that's a different problem than what @mick is describing then.  I'll be interested to see what you find out!